Bug 1080508 - Server fails to start if rhq.server.log-level is not explicitly defined in rhq-server.properties
Summary: Server fails to start if rhq.server.log-level is not explicitly defined in rh...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Upgrade
Version: JON 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: DR01
: JON 3.3.0
Assignee: John Mazzitelli
QA Contact: Filip Brychta
URL:
Whiteboard:
: 1080507 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-25 14:57 UTC by Larry O'Leary
Modified: 2018-12-04 17:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The JON Server failed to start when the "rhqctl install" command was run without the rhq.server.log-level property specified in the rhq-server.properties file. Customers who recently upgraded from a JON version not containing this parameter received ERROR log messages: "Cannot resolve expression 'expression "${rhq.server.log-level}". A fix to the rhqctl install parameter logic ensures servers now start when this parameter is not present. The ERROR log message has also been downgraded to an INFO log message, to realign the log message severity accordingly. Customers no longer experience the originally-reported issue.
Clone Of:
Environment:
Last Closed: 2014-12-11 13:59:38 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 759613 None None None Never
Red Hat Bugzilla 1078498 None None None Never

Internal Links: 1078498

Description Larry O'Leary 2014-03-25 14:57:30 UTC
Description of problem:
If the rhq-server.properties file is missing the property rhq.server.log-level, the JBoss ON server fails to start:

 JBAS014802: Cannot resolve expression 'expression "${rhq.server.log-level}"' -- java.lang.IllegalStateException: Failed to resolve expression: ${rhq.server.log-level}
	at org.rhq.common.jbossas.client.controller.LoggingJBossASClient.setLoggerLevel(LoggingJBossASClient.java:92) [rhq-jboss-as-dmr-client-4.9.0.JON320GA.jar:4.9.0.JON320GA]


This is common when upgrading from a previous version of JBoss ON that did not use this property. 

As with any property definition, a reasonable default should be used. In this case, the default seems to be INFO so it would make sense that the property expression use INFO as its default value and that this not be dependent on the rhq-server.properties file itself.

Version-Release number of selected component (if applicable):
3.2.0

How reproducible:
Always

Steps to Reproduce:
1. Extract JBoss ON 3.2 server archive.
2. Set server bind address in rhq-server.properties.
3. Remove rhq.server.log-level property from rhq-server.properties file.
4. Run install:
      rhqctl install

Actual results:
Install will fail with error:

    14:52:59,380 ERROR [org.rhq.enterprise.server.installer.Installer] The installer will now exit due to previous errors: org.rhq.common.jbossas.client.controller.FailureException: Failed request: JBAS014802: Cannot resolve expression 'expression "${rhq.server.log-level}"' -- java.lang.IllegalStateException: Failed to resolve expression: ${rhq.server.log-level}
        at org.rhq.common.jbossas.client.controller.LoggingJBossASClient.setLoggerLevel(LoggingJBossASClient.java:92) [rhq-jboss-as-dmr-client-4.9.0.JON320GA.jar:4.9.0.JON320GA]
        at org.rhq.enterprise.server.installer.ServerInstallUtil.configureLogging(ServerInstallUtil.java:187) [rhq-installer-util-4.9.0.JON320GA.jar:4.9.0.JON320GA]
        at org.rhq.enterprise.server.installer.InstallerServiceImpl.install(InstallerServiceImpl.java:333) [rhq-installer-util-4.9.0.JON320GA.jar:4.9.0.JON320GA]
        at org.rhq.enterprise.server.installer.Installer.doInstall(Installer.java:116) [rhq-installer-util-4.9.0.JON320GA.jar:4.9.0.JON320GA]
        at org.rhq.enterprise.server.installer.Installer.main(Installer.java:57) [rhq-installer-util-4.9.0.JON320GA.jar:4.9.0.JON320GA]
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.7.0_05]
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.7.0_05]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_05]
        at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_05]
        at org.jboss.modules.Module.run(Module.java:270) [jboss-modules.jar:1.2.2.Final-redhat-1]
        at org.jboss.modules.Main.main(Main.java:411) [jboss-modules.jar:1.2.2.Final-redhat-1]


Expected results:
Install should succeed with no error.

Comment 1 Larry O'Leary 2014-03-28 21:44:24 UTC
*** Bug 1080507 has been marked as a duplicate of this bug. ***

Comment 2 John Mazzitelli 2014-04-17 19:50:33 UTC
git commit to master: 0209557a16a9fc7ddb5a55a4faa055c352ff8d32
git commit to release/jon3.2.x: 0c56f68d2b6437a30f2b37829534c10321735f9a

If you run the installer without having rhq.server.log-level set in rhq-server.properties, the installation will now succeed.

Comment 3 Simeon Pinder 2014-07-31 15:51:49 UTC
Moving to ON_QA as available to test with brew build of DR01: https://brewweb.devel.redhat.com//buildinfo?buildID=373993

Comment 4 Filip Brychta 2014-08-05 11:58:03 UTC
Verified on
Version :	
3.3.0.DR01
Build Number :	
6468454:dda0a47

Comment 6 John Mazzitelli 2014-10-27 15:49:12 UTC
Looks good. Except I changed "JBoss Server" to "JON Server" since we don't need to explicitly say its a JBoss AS Server under the covers. Its just "the JON Server" to users.

Anyway, the "Doc Text" field looks good to me.


Note You need to log in before you can comment on or make changes to this bug.