Bug 108054 - Sending message results in segmentation fault when record and mbox are the same
Summary: Sending message results in segmentation fault when record and mbox are the same
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mutt (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-27 07:08 UTC by Leonid Mamtchenkov
Modified: 2014-03-17 02:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 19:02:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Leonid Mamtchenkov 2003-10-27 07:08:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031015
Firebird/0.7

Description of problem:
Sending message from mutt results in segmentation fault when mbox (incoming mail
folder) and record (sent mail folder) are set to the same value.  Appropriate
lines from the muttrc:

set mbox=~/Mail/in-inbox
set record=~/Mail/in-inbox

Segmentation happens when I send the message to a very long address, such as,
for example, used to confirm subscription to the mailing list.  I have seen this
problem with securityfocus.com and yahoogroups.com mailing lists.  

Short destination addresses do not cause any problems.  Also, if record is set
to a different folder from mbox, then no problem appears as well.

Version-Release number of selected component (if applicable):
mutt-1.4.1-1

How reproducible:
Sometimes

Steps to Reproduce:
1. Install mutt.
2. Add these two lines to the ~/.mutt/muttrc file:
set mbox=~/Mail/in-inbox
set record=~/Mail/in-inbox
3. Run mutt.
4. Change to ~/Mail/in-inbox mail foder.
5. Send message to a very long address (about 100-150 characters).

    

Actual Results:  The message is sent and a copy does appear in ~/Mail/in-inbox,
but mutt crashes with "Segmentation fault" message.

Expected Results:  No "Segmentation fault" necessary.

Additional info:

Comment 1 Bill Nottingham 2005-01-27 19:02:14 UTC
I've tested this with the FC3 mutt, and I can't reproduce the problem.

I wonder if this is a slang issue that's fixed with the switch to
ncurses. Please reopen if this persists on current Fedora Core or RHEL
releases.


Note You need to log in before you can comment on or make changes to this bug.