This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 108063 - Sun's Java JRE does not work with Red Hat after v.7.3
Sun's Java JRE does not work with Red Hat after v.7.3
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Robert Myers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-27 05:09 EST by TrakerJon
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-05 05:53:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description TrakerJon 2003-10-27 05:09:09 EST
Description of problem:

After successfully installing Sun's Java JRE 1.4.2_2 RPM for Linux and creating 
a symbolic link in the Mozilla plug-ins folder to libjavaplugin_oji.so 
following the directons found at 
http://plugindoc.mozdev.org/faqs/java.html...the plugins didn't work with 
Mozilla or Mozilla Firebird on any version of Red Hat after 7.3

Version-Release number of selected component (if applicable): 

1.2, 1.3, 1.4, 1.5


How reproducible:

Install Sun Java JRE from http://java.sun.com


Steps to Reproduce:
1. Open a terminal 
2. Change to your Mozilla (or Mozilla Firebird) plugins directory 
3. Issue the following command: ln -s /usr/java/j2re1.4.2_01/plugin/i386/ns610-
gcc32/libjavaplugin_oji.so 
    
Actual results:

Display prompts for installation of application/x-java-vm plugin

Expected results:

Java plugin works


Additional info:
Comment 1 TrakerJon 2003-10-27 20:03:02 EST

Please note that I used the following command: ln -
s /usr/java/j2re1.4.2_2/plugin/i386/ns610-
gcc32/libjavaplugin_oji.so not the fore mentioned.
Comment 2 Ngo Than 2003-10-29 11:21:32 EST
As i know there's some java versions, which does not work correct here.
Many people have reported that it works fine with j2re-SUN-1_4_2-linux-i586.rpm.



Comment 3 TrakerJon 2003-10-29 17:28:01 EST
I tried jre1.4.2_1 without success. Mandrake 9.1 works fine with both versions 
of java runtime, guess I'll have to reinstall Mandrake if Red Hat is unwilling 
to address issue.
Comment 4 Ngo Than 2003-10-30 09:54:21 EST
>1. Open a terminal 
>2. Change to your Mozilla (or Mozilla Firebird) plugins directory 
>3. Issue the following command: ln -s /usr/java/j2re1.4.2_01/plugin/i386/ns610-
>gcc32/libjavaplugin_oji.so 

i have downloaded j2re-1_4_2_02-linux-i586.rpm from sun, and installed
it on my machine. It works fine for me with this version and mozilla-1.4.1-15
from Fedora.

I did not find here the JRE 1.4.2_2 RPM, which you have!

please make sure that you have install the correct mozilla from Red Hat.

Comment 5 TrakerJon 2003-10-30 17:02:11 EST
Sun's latest version of Java Runtime can be found at...

http://java.sun.com/j2se/1.4.2/download.html
Comment 6 TrakerJon 2003-10-30 17:03:18 EST
I used the version of Mozilla that came with the current Red Hat release.
Comment 7 Robert Myers 2003-11-05 18:17:27 EST
Working with Fedora Core Severn 3.

From the web address you identified, you can get

j2re-1_4_2_02-linux-i586-rpm.bin

It self-extracts, and you have to be sure to do 

rpm -Uvh j2re-1_4_2_02-linux-i586-rpm.bin

In the Mozilla plugins directory, you need to do

cd /usr/lib/mozilla-1.4.1/plugins
ln -s
/usr/java/j2re1.4.2_02/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so

And it works.  It did not work for me with version 1.4.1_01, either.

RM
Comment 8 TrakerJon 2003-11-07 08:25:09 EST
Ok, downloaded the final release or Red Hat-Fedora followed your 
instructions to the letter. Mozilla still did not recognize the java 
vm plugin. I had to login as root to follow your directions, wouldn't 
allow me to install as a user. It made the symbolic link fine but 
when I launch Mozilla (the one that Fedora shipped with) and look 
under plugins it's not recognize nor does it work on pages that 
require the plugin. No offense but Mandrake 9.1 recognizes Sun's java 
plugin immediately after the rpm install without additional effort on 
my part (Red Hat 7.3 does the same thing). What has changed or what 
isn't working that makes this so difficult to make Sun's java vm work?
Comment 9 Ngo Than 2003-11-12 16:29:30 EST
you should check if there's a broken java plugin in following
directorires:

 $HOME/.mozilla
 /usr/lib/mozilla



Comment 10 TrakerJon 2003-11-12 23:08:40 EST
I reinstalled the final release once again, followed all the 
instructions given by you and Mozilla. The plugin and sybolic links 
are where they're supposed to be and still do not work or show up in 
the Mozilla browser under the plugins information. Flash and 
Realplayer plugins work fine. I have an Intel system board with an 
810 chipset, 600Mhz with 512Mb SDRAM. Once again, as I have stated 
before, Sun's Java has yet to work with any Red Hat release since 
v7.3 and no one can tell me why. Many other people have the same 
problem as well. Will you guys please fix this so that the user 
doesn't have to jump through 10 hoops after installing Sun's Java RPM?
Comment 11 Bart Martens 2003-12-24 15:19:27 EST
Download J2SE v 1.4.2_03 - SDK, execute the .bin-file, install the
rpm, then make the symbolic link with ln -s
/usr/java/j2sdk1.4.2_03/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so
/usr/lib/mozilla/plugins, and then restart mozilla. Works! I don't see
the problem.

mozilla-1.4.1-18
j2sdk-1.4.2_03-fcs

I suggest to close this bug report.
Comment 12 TrakerJon 2003-12-26 21:50:52 EST
So what you're saying is that unlike other linux distributions such 
as Mandrake and Debian in which you only have to install the JRE, the 
SDK (software devlopment kit) is required under Fedora in order for 
Sun's Java VM to work within the Mozilla browser? Somehow that seems 
incorrect but I'll give it a try.
Comment 13 TrakerJon 2003-12-26 21:58:14 EST
I tried what you suggested without success. I find it ironic that Red 
Hat/Fedora requires manual configurations to begin with much less the 
Java SDK. Most linux distributions only require that you simply 
install the java JRE with no additional effort on the part of the 
user (as it did with Red Hat 7.3). The creation of sybollic links 
should not be required, this seems to be a design flaw within all the 
Red Hat releases since 7.3.
Comment 14 Bart Martens 2003-12-27 05:54:01 EST
> So what you're saying is that (...)
> the SDK is required under Fedora

No, that's not what I said.

> I tried what you suggested without success.

I understand that you're having difficulties, and that you need
support. I'm not convinced that there is a bug. Let's continue this
conversation on the fedora users mailing list or on usenet.

I suggest to close this bug report.
Comment 15 TrakerJon 2004-01-05 05:53:05 EST
Ok guys, I downloaded the final release Fedora Core again (noticed a
few changes since the previous one) and Sun's Java VM now works.
Comment 16 TrakerJon 2004-01-05 05:55:03 EST
Thanks for all your help, I'm using Fedora Core now.

Note You need to log in before you can comment on or make changes to this bug.