This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 108076 - Java form Matlab 6.5 cannot start with NPLT or LD_ASUME_KERNEL
Java form Matlab 6.5 cannot start with NPLT or LD_ASUME_KERNEL
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
i686 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-27 09:08 EST by bednar
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 04:18:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description bednar 2003-10-27 09:08:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The Java VM supplied with Matlab 6.1 and 6.5 cannot run with RHL 9 or Fedora
because of Native Posix Threads implemented in the kernel, but in Red Hat Linux
9 it was possible to start matlab with java after setting environment variable
LD_ASSUME_KERNEL=2.4.1. Now this trick doesn't work :(


Version-Release number of selected component (if applicable):
standard kernel of Fedora Test 3

How reproducible:
Always

Steps to Reproduce:
1.type in CLI: LD_ASSUME_KERNEL=2.4.1
2.run matlab
3.
    

Actual Results:  Java Support Disabled

Expected Results:  Working JAVA GUI of Matlab

Additional info:
Comment 1 bednar 2003-11-21 13:16:57 EST
Now I'm using Fedora Core 1 and java built in matlab 6.1 stiil doesn't
work (I read about similar problem with java on
http://www.mail-archive.com/tomcat-user@jakarta.apache.org/msg110209.html
)
Here is the output from matlab:

[root@localhost bin]# matlab
Warning: Unable to load Java Runtime Environment:
/usr/local/matlab6p1/sys/java/jre/glnx86/jre/lib/i386/native_threads/libjava.so:
symbol __libc_wait, version GLIBC_2.0 not defined in file libc.so.6
with link time reference.
Warning: Disabling Java support.

Whot is worse, I tried export LD_ASSUME_KERNEL=2.2.5 
and 2.4.1 and 2.4.19. None of these work.
The problem is very important for many of people who make serious job
on linux.

When I changed MATLAB_JAVA environment variable to point SUN's java
1.4.2 the matlab start with java GUI but, after opening one more
window of matlab (like editor or preferences) matlab freezes. I use
system locale pl_:PL and have SUN's java 1.4.2 with locale for
en,gb,de,es. I don't know if it could be locale problem or maybe NPTL
or glibc because I cannot find any log from java crash.
Comment 2 Miloš Komarčević 2003-12-20 12:00:32 EST
When I tried (FC1+Matlab 6.0) to change MATLAB_JAVA to point to SUN's
Java 1.4.2 I got another error

libjvm.so: cannot open shared object file: No such file or directory

so I had to include the java libraries in LD_LIBRARY_PATH in order to
make it start, but it does indeed freeze here as well if I open
another window (this is on en_GB locale)

I could only run Matlab normally on FC1 with the fix suggested in bug
110610 and the original JRE supplied with Matlab.
Comment 3 bednar 2003-12-21 09:29:00 EST
Me too. I've also tried to change JVM to 1.4.2 with same effects. I
think we should write to the Matworsk directly> I tried, because I
have licenced Matlab bought at my work, but I have to ask the
administartor of licence server of some number (I don't remeber its
name). The licence number is not enough to send a question to the
Matworks support team.
I'll send the results (if there will any) after contatc with Mathworks.
Comment 4 Miloš Komarčević 2004-01-22 09:02:25 EST
Ok, just upgraded to Matlab 6.5 (w/ jre1.3.1), and with the latest
glibc update (glibc-2.3.2-101.4) I can run Matlab just fine without
any workarounds! I hope you'll be able to confirm this too.

The only problem I have now is Java complaining about some missing fonts, 

http://www.mathworks.com/support/solutions/data/31607.shtml

which I solved by copying over font.properties.Redhat8.0 from j2re1.4.2
Comment 5 bednar 2004-01-22 11:40:26 EST
I can run matlab 6.5 without tricks too. But: 6.5 has (I think that
its true) bug in Power Sim Blockset and jvm supplied with 6.5 has ugly
big, curved, unreadable fonts. I'm seeking a solution to the fonts in
JVM problem. Does abybody know how to change jvm fonts?
Comment 6 David Kewley 2004-02-19 19:31:44 EST
I don't know that this bug needs to stay open; it doesn't see like a
RHL / FC problem.

See my comment(s) and those of Jakub in bug 110610 (which started with
an identical report from bednar, and is now closed).

I'll mention here in response to comment #2 that another way (if you
have root privs) to avoid the libjvm.so complaint when trying J2RE
1.4.2 is to make a symlink like this:

ln -s /usr/java/j2re1.4.2/lib/i386/server/libjvm.so \
    $MATLAB_ROOT/bin/glnx86

This is a hack really, from doing an 'strace' on matlab and seeing
where it was looking for libjvm.so.  Really Mathworks need to fix
their bugs.

Today I filed a bug report with Mathworks regarding the fact (in my
experience at least) that on RHL 9, Matlab R12.1, R13, and R13SP1 all
render text lines on the Java desktop with too much whitespace between
lines, wasting screen area.  Interestingly for RH folks, Matlab R12.1
doesn't have this problem on RHL 8.0.  This could be a bug for RH to
squash, but I have no idea where to file it.

I also mentioned to Mathworks some of the headaches we're all seeing
regarding installing new JRE/J2RE.  The first line of my bug report
requested a human response; we'll see if they do reply.

Also note that Matlab R14 is coming out in mid-2004, so *hopefully*
it'll fix some of these issues.  I'm not holding my breath though.
Comment 7 Stephen Walton 2004-03-14 19:05:39 EST
Just an FYI:  Matlab 13 with Service Pack 1 works mainly OK on Fedora,
with the font fixes which Mathworks itself recommends.  The exception
to the "mainly OK" I've found is the Print command from the M-file
editor, which doesn't work with either Java 1.3.1 or 1.4.2.
Comment 8 William Lovaton 2004-05-10 15:39:31 EDT
I have the very same problem with Java on my fresh FC2 Test 3 system.
 But this time I am trying to install Oracle 9i (9.2.0.1.0).  With the
JVM shipped in the Oracle Universal Installer I got the very same
message as bednar shows in comment #1.

I got it to run in two ways 1) Using another JVM (Blackdown 1.3.1) and
2) Following the steps indicated in bug #110610 Comment #1 from Jakub
Jelinek.

The bad news for me is that it doesn't execute the buttons.  It
started but when I hit the "Next" button to start the installation
process, it doesn't do any thing.  It isn't blocked, it just sits
there and do nothing.  Others buttons works like "About..." and
"Uninstall products" but the rest of the buttons doesn't.  It doesn't
even show a message on the terminal.  Nothing!. :-(

I got the same from Oracle 8.1.7.  Have in mind that I just need the
client installation, I'm not trying to setup a server on Linux.

Oracle 9i installation used to work in RH9 (2.4.20) and it worked
flawlessly in Mandrake 10 with kernel 2.6.3.

Have anyone tried to install Oracle in FC2??


-William
PS. I'll subscribe to fedora-test-list and post a link to this bug.
BTW FC2 rocks!
Comment 9 Ulrich Drepper 2004-09-28 04:18:46 EDT
I close this bug.  Nothing here is a problem in glibc.  Yes, all JVMs
had problems and got updated.

Note You need to log in before you can comment on or make changes to this bug.