Bug 108084 - REMOTE_USER environment variable not set
Summary: REMOTE_USER environment variable not set
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: mod_auth_pgsql
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-27 15:06 UTC by Tomas Edwardsson
Modified: 2007-04-18 16:58 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-03-06 12:15:06 UTC


Attachments (Terms of Use)
Fixed the REMOTE_USER not set problem (671 bytes, text/plain)
2003-10-27 15:07 UTC, Tomas Edwardsson
no flags Details

Description Tomas Edwardsson 2003-10-27 15:06:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031022
Firebird/0.7

Description of problem:
The REMOTE_USER is not set like in the standard authentication mechanism. This
can be fixed with a quick patch which will follow.

Version-Release number of selected component (if applicable):
mod_auth_pgsql-2.0.1-3

How reproducible:
Always

You can reproduce this with a small perl cgi script or whatever. I'm attaching a
patch that addresses this problem.

Comment 1 Tomas Edwardsson 2003-10-27 15:07:56 UTC
Created attachment 95515 [details]
Fixed the REMOTE_USER not set problem

Comment 2 Tomas Edwardsson 2003-10-27 15:09:04 UTC
Ohh, also, I've already sent this patch to the maintainer and gotten no reply.
So to get this fixed in my favorite distro I've decided to post it here.

Comment 3 Tomas Edwardsson 2004-03-06 12:15:06 UTC
Never addressed so I'm just posting a new bug on Fedora Core test1


Note You need to log in before you can comment on or make changes to this bug.