Bug 1080960 - RFE: implement systemctl reload
Summary: RFE: implement systemctl reload
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sssd
Version: 7.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: SSSD Maintainers
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-26 11:35 UTC by Amith
Modified: 2017-08-07 20:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-07 20:20:39 UTC


Attachments (Terms of Use)

Description Amith 2014-03-26 11:35:28 UTC
Description of problem:
Command "systemctl reload sssd" fails with the following error:
Failed to issue method call: Job type reload is not applicable for unit sssd.service.

Version-Release number of selected component (if applicable):
sssd-1.11.2-40.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Execute "# systemctl reload sssd" and see the failure.

Comment 1 Lukas Slebodnik 2014-03-26 11:42:34 UTC
man systemctl says:
       reload NAME...
           Asks all units listed on the command line to reload their
           configuration. Note that this will reload the service-specific
           configuration, not the unit configuration file of systemd. If you
           want systemd to reload the configuration file of a unit, use the
           daemon-reload command. In other words: for the example case of
           Apache, this will reload Apache's httpd.conf in the web server, not
           the apache.service systemd unit file.

           This command should not be confused with the daemon-reload or load
           commands.

SSSD does not implement reloading configuration on the fly. If you want to reload configuration you will need to restart sssd.

I would say this is not a bug but only RFE

Comment 3 Jakub Hrozek 2014-03-31 09:51:08 UTC
(In reply to Lukas Slebodnik from comment #1)
> I would say this is not a bug but only RFE

Right, we could implement an ExecReload=pkill -HUP sssd or something similar, but I don't think it's needed.

Comment 4 Jakub Hrozek 2014-03-31 09:52:30 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2292

Comment 5 Jakub Hrozek 2014-04-03 10:31:12 UTC
Upstream ticket:
https://fedorahosted.org/sssd/ticket/2243

Comment 6 Jakub Hrozek 2014-04-03 10:34:20 UTC
As agreed on the SSSD meeting on 03-27, this bug should be looked at when we work on socket activating the services. For now, I'll re-propose for 7.1 to get the bz off the 7.0 radar.

Comment 7 Jakub Hrozek 2016-01-08 11:00:58 UTC
Although Simo is working on socket-activating the Custodia responder, we don't plan on making all services socket activatable by default, so this bugzilla should be looked at again in the 7.4 timeframe.

Comment 8 Lukas Slebodnik 2017-01-23 17:57:12 UTC
Upstream ticket #2243 is fixed but "systemctl reload" is not implemented there.

Comment 9 Jakub Hrozek 2017-08-07 20:20:39 UTC
I don't think we will implement systemctl reload per se, so I'm going to close this ticket. 

What would IMO make value to track in RHEL is https://pagure.io/SSSD/sssd/issue/3352 instead.


Note You need to log in before you can comment on or make changes to this bug.