Bug 108097 - install exited abnormally during 7.1 upgrade
install exited abnormally during 7.1 upgrade
Status: CLOSED WORKSFORME
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda (Show other bugs)
beta2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-27 12:19 EST by Mike McLean
Modified: 2007-04-18 12:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 08:58:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike McLean 2003-10-27 12:19:27 EST
* Cambridge-re1024.nightly
* upgrade-errata-7.1-french-http-TUI-everything

There was nothing helpful on the console just typical 'install exited
abnormally' spew.

FWIW, an upgrade from 7.1 minimal succeeded earlier on this same
machine (Proliant DL380 G1 with cpqarray).
Comment 2 Jeremy Katz 2003-10-27 14:37:43 EST
Reproducible?
Comment 3 Mike McLean 2003-10-27 16:54:13 EST
7.0 minimal upgrade sez "error reading information on service
linuxconf: No such file or directory" right before it dies, but I'm
not sure if the message has anything to do with the crash.
Comment 4 Jeremy Katz 2003-10-27 17:26:06 EST
Hmmm, did 7.1 minimal + linuxconf install and it's upgrading fine now :/
Comment 5 Mike McLean 2003-11-04 13:04:10 EST
This problem affects 7.0, 7.1, and 7.2 installs.  The installer exits
abnormally during the "Preparing to install" phase.

upgrade from minimal installs seem to be ok.  upgrades from everything
installs fail.  I ran a testcase upgrading from 7.2 minimal+linuxconf
-- it failed.
Comment 6 Mike McLean 2003-11-04 13:12:32 EST
Confirmed that manually upgrading from 7.2 min+linuxconf also fails
Comment 7 Mike McLean 2003-11-04 13:14:35 EST
I think the message "error reading information on service linuxconf:
No such file or directory" only appears when you try the upgrade again
after it has failed.  Presumably anaconda manages to remove linuxconf
before it dies.
Comment 8 Jeremy Katz 2003-11-04 13:16:55 EST
Almost certainly the linuxconf removal code... workaround is to remove
linuxconf manually by hand beforehand.

As I said last week, though, I'm not convinced this is going to be a
huge problem -- upgrades from 7.x to Fedora aren't what I expect to be
common.
Comment 9 Mike McLean 2003-11-04 13:33:50 EST
Hmm, anaconda doesn't quite manage to remove linuxconf.  All the files
are removed, but the entry remains in the rpm database.
Comment 10 ASD Webmaster 2003-12-08 16:51:51 EST
I ran into this same problem intalling RHEL AS 2.1 for i386 update 2
on a Compaq Proliant (w/ 3 disk raid). Repartitioned/formatted, via
anaconda -- so it does not appear to be an upgrade issue. Tried
ide=nodma -- no luck. <Ctrl>+<Alt>+<F4> shows a whole bunch of
cdrom_decode_status/SeekComplete errors.

Red Hat 7.2, 7.3, and 8.0 all installed and ran on this precise
hardware configuration w/o error . . .
Comment 11 Jeremy Katz 2004-10-04 17:45:36 EDT
Does this still happen?
Comment 12 Jeremy Katz 2004-11-04 08:58:40 EST
Closing due to inactivity.  Please reopen this bug if you have further
information to add to the report.

Note You need to log in before you can comment on or make changes to this bug.