Bug 108113 - iptables hangs on "service iptables stop"
Summary: iptables hangs on "service iptables stop"
Status: CLOSED DUPLICATE of bug 103177
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iptables   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Ben Levenson
URL: none
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-27 18:27 UTC by charles schick
Modified: 2007-04-18 16:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description charles schick 2003-10-27 18:27:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030716

Description of problem:
service iptables stop

during the script, the iptables modules are removed using 

modprobe -r module_name

and modprobe hangs while attempting to remove iptables modules.

happens only when ip_conntrack_ftp is in use

Version-Release number of selected component (if applicable):
iptables-1.2.8-8.80.2

How reproducible:
Always

Steps to Reproduce:
modprobe ip_nat_ftp
start an ftp session to the box where these modules & iptables live
close ftp session
service iptables stop


Actual Results:  ps -eaf | grep modprobe  

root      3007  2939 99 19:25 pts/2    00:00:11 modprobe -r ip_nat_ftp

reveals that module doesn't unload and proc goes to 99% -- requires reboot

Expected Results:  modules should have been unloaded sucessfully

Additional info:

p[lease help!

Comment 1 Thomas Woerner 2003-11-03 10:06:34 UTC

*** This bug has been marked as a duplicate of 103177 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:59:27 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.