Bug 108124 - The interative parameter prompt doesn't let user confirm / edit values before running
The interative parameter prompt doesn't let user confirm / edit values before...
Status: CLOSED RAWHIDE
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rafael H. Schloming
Jon Orris
:
Depends On:
Blocks: 106597
  Show dependency treegraph
 
Reported: 2003-10-27 15:24 EST by Daniel Berrange
Modified: 2014-12-01 18:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-07 17:48:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2003-10-27 15:24:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
The interative parameter prompter run in the package loader doesn't let user
confirm / edit values they enter before running. For example, it prompts for the
admin email, name, password, etc, and if you make a typo you have no opportunity
to correct it, so you then have to drop & reload the entire DB.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Enter a typo for the admin email address
2.
3.
    

Actual Results:  No opportunity to correct it

Expected Results:  Confirm step lets you review & re-edit parameters before running

Additional info:
Comment 1 Vadim Nasardinov 2003-10-27 15:38:57 EST
You can use the -defaults switch to pass in a file
with name=value pairs.  Both ConfigTool (ccm-conf)
and PackageTool (ccm-pkg) take the -defaults switch.

Grep //users/vadim/docs/config/ccm-packaging.txt
for my.defaults to see an example.

Comment 2 Richard Li 2003-10-27 15:48:21 EST
What we will do for Oct 30 is, for WAF:

1. Prompt for all the database-persistent settings.
2. Prior to persisting in the database, present a summary screen for the user,
with all the user-input settings.
3. Allow the user to go back to the beginning or persist to the database.

Time permitting, we will also enable editing each item line-by-line.

We will not do this for anything other than Core (which should be okay, I think,
since the other app bootstraps do not persist stuff into the database). Let me
know if this is not the case.
Comment 3 Daniel Berrange 2003-10-27 16:02:01 EST
This sounds reasonable. Line-by-line re-editing is an optimization that isn't
critical for Oct 30 given the number of parameters for core is a mere five.

> We will not do this for anything other than Core

Is the interactive reading really custom code to the Core loader ? Ultimately it
would be better if this were part of the general config parameter infrastructure
& thus automatically available to all apps loaders, but again not critical for
Oct 30
Comment 4 Rafael H. Schloming 2003-10-27 16:52:12 EST
The functionality is not custom to core loader, but it will depend on removing
usage of the deprecated ScriptContext.getParameterLoader() for parameters that
require confirmation. This has already been done for CoreLoader, but not for
other Loaders, so we can't guarantee that other loaders will get confirmation.

Note You need to log in before you can comment on or make changes to this bug.