Bug 108125 - Loader should check dependant initializers before loading data model
Loader should check dependant initializers before loading data model
Status: CLOSED RAWHIDE
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Ross
Jon Orris
:
Depends On:
Blocks: 106481
  Show dependency treegraph
 
Reported: 2003-10-27 15:28 EST by Daniel Berrange
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-26 17:37:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2003-10-27 15:28:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
The command line loader tool doesn't validate the initializer dependencies until
after it has loaded the data model for an application. This causes a delay in
the detection of unsatisfied installation dependencies. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load ccm-core data model only
2. Load ccm-cms
3.
    

Actual Results:  No error about missing com.arsdigita.core.Initializer
dependency until after CMS data model has loaded

Expected Results:  Missing dependency is highlighted immediately

Additional info:
Comment 1 Justin Ross 2004-01-26 14:30:58 EST
Fixed in perforce change 39763.  It's only reproducible if you disable
some of the other dependency checks, since the package dep check, for
instance, catches the problem for the above example first.

Note You need to log in before you can comment on or make changes to this bug.