Bug 1081271 - OSMajor field in task search bar is actually searching excluded OSMajors
Summary: OSMajor field in task search bar is actually searching excluded OSMajors
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: web UI
Version: 0.16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 24.0
Assignee: Tyrone Abdy
QA Contact: tools-bugs
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-26 23:27 UTC by Dan Callaghan
Modified: 2018-02-06 00:41 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-02-21 18:49:11 UTC


Attachments (Terms of Use)

Description Dan Callaghan 2014-03-26 23:27:00 UTC
Description of problem:
Search bar says "OSMajor" but it's actually searching task excluded OSMajors which is essentially the opposite of what it looks like.

Version-Release number of selected component (if applicable):
0.16.0

Steps to Reproduce:
1. Select Scheduler -> Task Library
2. Search for OSMajor contains RedHatEnterpriseLinux7

Actual results:
Search results shows tasks which *exclude* RedHatEnterpriseLinux7.

Expected results:
Search should match what it's actually searching. I think the best solution is for the search to be labelled as "Excluded OSMajor". So then searching Excluded OSMajor contains RedHatEnterpriseLinux7 would correctly return tasks which exclude RedHatEnterpriseLinux7.

Comment 2 Dan Callaghan 2016-11-03 05:54:28 UTC
(In reply to Dan Callaghan from comment #0)
> Search should match what it's actually searching. I think the best solution
> is for the search to be labelled as "Excluded OSMajor". So then searching
> Excluded OSMajor contains RedHatEnterpriseLinux7 would correctly return
> tasks which exclude RedHatEnterpriseLinux7.

Tyrone did this as part of bug 1346620.

Comment 5 Dan Callaghan 2017-02-21 18:49:11 UTC
Beaker 24.0 has been released.


Note You need to log in before you can comment on or make changes to this bug.