Bug 1081287 (CVE-2014-2681, CVE-2014-2682, CVE-2014-2683) - CVE-2014-2681 CVE-2014-2682 CVE-2014-2683 php-ZendFramework: XML eXternal Entity (XXE) and XML Entity Expansion (XEE) flaws fixed in 1.12.4, 2.1.6, and 2.2.6 (ZF2014-01)
Summary: CVE-2014-2681 CVE-2014-2682 CVE-2014-2683 php-ZendFramework: XML eXternal Ent...
Status: CLOSED ERRATA
Alias: CVE-2014-2681, CVE-2014-2682, CVE-2014-2683
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=important,public=20140306,repo...
Keywords: Security
Depends On: 1081290 1081291 1081292 1081293
Blocks: 1081297
TreeView+ depends on / blocked
 
Reported: 2014-03-27 02:03 UTC by Murray McAllister
Modified: 2019-06-08 19:58 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-05-30 03:34:32 UTC


Attachments (Terms of Use)

Description Murray McAllister 2014-03-27 02:03:41 UTC
XML eXternal Entity (XXE) and XML Entity Expansion (XEE) flaws were discovered in the Zend Framework. An attacker could use these flaws to cause a denial of service, access files accessible to the server process, or possibly perform other more advanced XML External Entity (XXE) attacks.

These issues have been fixed in versions 1.12.4, 2.1.6, and 2.2.6.

External References:

http://framework.zend.com/security/advisory/ZF2014-01

Comment 1 Murray McAllister 2014-03-27 02:06:55 UTC
Created php-ZendFramework2 tracking bugs for this issue:

Affects: fedora-all [bug 1081291]
Affects: epel-6 [bug 1081293]

Comment 2 Murray McAllister 2014-03-27 02:07:00 UTC
Created php-ZendFramework tracking bugs for this issue:

Affects: fedora-all [bug 1081290]
Affects: epel-6 [bug 1081292]

Comment 3 Murray McAllister 2014-03-27 02:18:32 UTC
CVE request: http://www.openwall.com/lists/oss-security/2014/03/27/1

Comment 4 Murray McAllister 2014-04-01 06:35:30 UTC
MITRE assigned a number of CVEs. Quoting from http://seclists.org/oss-sec/2014/q2/0

""
CVE-2014-2681 - This CVE is for the lack of protection against XML
External Entity injection attacks in some functions, because of the
incomplete fix in CVE-2012-5657. It appears that this only affects
Zend Framework 1.x, although that isn't critical to determining the
number of CVE IDs.

CVE-2014-2682 - This CVE is for the failure to consider that the
libxml_disable_entity_loader setting is shared among threads in the
PHP-FPM case. Again, the existence of this CVE means that the
CVE-2012-5657 fix was incomplete. It appears that this affects more
than just Zend Framework 1.x, although that isn't critical to
determining the number of CVE IDs.

CVE-2014-2683 - This CVE is for the lack of protection against XML
Entity Expansion attacks in some functions, because of the incomplete
fix in CVE-2012-6532. It appears that this also affects more than just
Zend Framework 1.x, although that isn't critical to determining the
number of CVE IDs.
""

Comment 5 Fedora Update System 2014-04-14 22:34:50 UTC
php-ZendFramework-1.12.5-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2014-04-14 22:36:01 UTC
php-ZendFramework-1.12.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2014-04-14 22:40:43 UTC
php-ZendFramework2-2.2.6-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-04-14 22:45:30 UTC
php-ZendFramework2-2.2.6-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-04-22 19:57:15 UTC
php-ZendFramework2-2.2.6-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-06-30 03:37:30 UTC
php-ZendFramework-1.12.5-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.