Bug 108134 - Support for Bluetooth HIDs
Support for Bluetooth HIDs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-27 16:52 EST by Bernhard Harb
Modified: 2015-01-04 17:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 18:35:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Harb 2003-10-27 16:52:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Is it possible to include the "Bluetooth-HID-Driver" from  
http://www.visi.com/~pmk/msbtkb-linux.html with Fedora Core or to distribute a 
RPM with that driver in Rawhide?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Not a Bug, it's a new feature.

Additional info:
Comment 1 David Woodhouse 2003-10-27 17:36:34 EST
The userspace part of this is fine, if it's indeed going to be done in
userspace. It's the kernel side which wants fixing. The problem with using evdev
is probably that it's not possible to _create_ input devices using evdev,
although it looks like you can inject events for existing devices. 

Reassigning to kernel.
Comment 2 Brian Stretch 2004-05-08 12:02:11 EDT
Could CONFIG_INPUT_UINPUT be enabled in the prebuilt 2.6 series
kernels so that a kernel recompile won't be required for people who
want to use this driver?  I also think this takes care of the kernel
issue you had with the 2.4 kernel, so including the
Bluetooth-HID-Driver may be OK now?  See the end of the
msbtkb-linux.html page.  The 2.6 port was done on 12-30-2003. 

FYI, I was able to get the Bluetooth module in my HP zv5000z Athlon 64
notebook to work with Fedora Core 2 Test 3, enough to have it scan my
Microsoft Bluetooth Mouse, but I haven't had time to finish getting it
configured.  The internal Bluetooth module shows up as a standard USB
Bluetooth device.  Nice. 
Comment 3 Mark 2004-08-11 21:11:43 EDT
As of Kernel 2.6.7, HID support has been added to the kernel(per
marcel holtman, see bluez.org).  The question I have is not
necessarily so much for anaconda.  I doubt most could care less if the
BT mouse/keyboard work at install but I think most of us would like to
see KUDZU be able to configure for these devices.

Anybody agree/disagree with that?

It's about time that Linux had bluetooth devices enabled with some
ease.  It'd be nice if FC3 is the first in line.
Comment 4 Dave Jones 2004-11-03 00:03:29 EST
current kernels for FC3 (and soon, the update for FC2) should have this fixed.

Note You need to log in before you can comment on or make changes to this bug.