Bug 1081374 - "Remove Hardware" context memu displayed for none hardware item on guest detail page and could not work.
Summary: "Remove Hardware" context memu displayed for none hardware item on guest deta...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1081373
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-27 06:16 UTC by zhengqin
Modified: 2014-03-27 07:56 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1081373
Environment:
Last Closed: 2014-03-27 07:56:43 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description zhengqin 2014-03-27 06:16:53 UTC
+++ This bug was initially created as a clone of Bug #1081373 +++

Description of problem:
Version-Release number of selected component:
virt-manager-0.10.0-20.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Start virt-manager with --debug.

2. Open a guest's detail page.

3. Right-click on "Overview" item, and the context memu pops up with options "Add Hardware" and "Remove Hardware".

4. Choose option "Remove Hardware".

Actual result:
1. Debug error will pop up "AttributeError: str object has no attribute 'virtual_device_type'"
----------------------------------------------------------------
2014-03-27 13:37:56,618 (details:576): Showing VM details: <vmmDomain object at 0x2764d70 (virtManager+domain+vmmDomain at 0x1b7fae0)>
2014-03-27 13:38:01,480 (cliutils:87): Uncaught exception:
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/details.py", line 1532, in remove_xml_dev
    devtype = info.virtual_device_type
AttributeError: 'str' object has no attribute 'virtual_device_type'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/details.py", line 1532, in remove_xml_dev
    devtype = info.virtual_device_type
AttributeError: 'str' object has no attribute 'virtual_device_type'
----------------------------------------------------------------
2. There is no response when choosing "Remove Hardware"
3. There is no "Remove" button at right-lower window for Overview page.


Expected results:
1. "Remove Hardware" option should be removed on context memu since "Overview" is not a hardware.





Additional info:
1. This issue also occurs on RHEL6.
2. This issue also occurs for "Performance", "Processor", "Memory" and "Boot Options"
3. Could not remove Mouse if only one mouse device exists.

Comment 1 zhengqin 2014-03-27 06:17:42 UTC
This issue also occurs on latest RHEL6u5, so clone it.

Comment 2 Giuseppe Scrivano 2014-03-27 07:56:43 UTC
this issue doesn't seem so severe that needs to be addressed for 6.x.  Closing it as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.