Bug 108138 - Radeon 9200 ChipID 0x5964 not detected
Radeon 9200 ChipID 0x5964 not detected
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-27 17:41 EST by Jason Tibbitts
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-27 14:27:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output (8.03 KB, text/plain)
2003-10-27 17:42 EST, Jason Tibbitts
no flags Details
log without ChipID 0x5963 (16.85 KB, text/plain)
2003-10-27 17:43 EST, Jason Tibbitts
no flags Details
log with ChipID 0x5963 (40.37 KB, text/plain)
2003-10-27 17:43 EST, Jason Tibbitts
no flags Details

  None (edit)
Description Jason Tibbitts 2003-10-27 17:41:33 EST
I have a cheap Radeon 9200 with chip ID 5964 which is not detected by
XFree86-4.3.0-42 (rebuilt for Red Hat 9).  Everything works if I force a ChipID
of 0x5963.

Looking at XFree86-4.3.0-radeon-support-backport-from-CVS-v2.patch, I would
assume that this card would be detected fine because that chip ID is explicitly
added in several places in that patch.  Just for grins I tried forcing a ChipID
of 0x5964 to make sure it wasn't a detection issue but the server errors out with:

(WW) RADEON: ChipID 0x5964 in Device section "Videocard0" isn't valid for this
driver

I will attach lspci -vvv and XFree logs both with and without the ChipID
specified as 0x5963.
Comment 1 Jason Tibbitts 2003-10-27 17:42:19 EST
Created attachment 95532 [details]
lspci output
Comment 2 Jason Tibbitts 2003-10-27 17:43:05 EST
Created attachment 95533 [details]
log without ChipID 0x5963
Comment 3 Jason Tibbitts 2003-10-27 17:43:54 EST
Created attachment 95534 [details]
log with ChipID 0x5963
Comment 4 Jason Tibbitts 2003-11-04 16:01:59 EST
Just a quick note that after more experimentation I found that any 3D
application would hang immediately upon starting if I used that
ChipID.   My guess is that this card is a cheap or slow version of a
regular Radeon 9200 and can't tolerate the same timings.  Right now
I'm using ChipID 0x4967 and everything is working great.
Comment 5 Mike A. Harris 2003-11-04 18:26:28 EST
The problem is very unlikely to be due to cheap hardware.  The
support for Radeon 9200 is semi-experimental, but works for some
people.  I am collecting bug reports on various non-working Radeon
hardware and trying to find commonalities between reported problems.

I will be working on the various reported problems sometime within
the next month or so, and hopefully can work out any glitches that
have been reported.

Your newly supplied information should be useful when I get to
tackling this also.  If you figure out anything else new that you
think might be useful, please add it to the report too.

TIA
Comment 6 Warren Togami 2004-02-29 03:22:14 EST
Jason Tibbits, any newer test results with FC1 or FC2 test?
Comment 7 Jason Tibbitts 2004-02-29 12:31:13 EST
I haven't upgraded a machine with this card yet, but I have some spare
cards around so I'll try to build up a machine and test it out this week.
Comment 8 Jason Tibbitts 2004-03-15 14:59:21 EST
Just had occasion to try FC1 on a machine with this card; it was not
detected and the box came up in VESA mode as RH9 did. XFree version is
4.3.0-55.

I haven't started to move on FC2 as of yet, but I'll report back when
I have a chance to try it.  Alternately I can ship a card to someone;
I have several in the spares drawer.
Comment 9 Warren Togami 2004-03-15 15:11:47 EST
You can give the XFree86 in rawhide a try on FC1.  I think it is kept
in sync across both distributions.
Comment 10 Jason Tibbitts 2004-03-15 16:28:06 EST
I updated XFree86* from my local Fedora mirror and edited
/etc/X11/XF86Config to change "vesa" to "radeon"; everything seems to
come up OK. OpenGL apps are stableas well.

I'm not sure how to test that a fresh install will properly detect the
chipset, however.
Comment 11 Mike A. Harris 2004-03-15 17:57:32 EST
rawhide XFree86 is meant more to be used with Fedora Core development,
and may or may not work at all in Fedora Core 1.  The XFree86
spec file inside the src.rpm is kept in a state that is used
to generate rpms for as far back as Red Hat Linux 8.0, however
there are various aspects of the spec file which are OS release
independant and may end up breaking your OS in subtle ways,
if you install binaries generated for one release on another, or
in other cases it may make your system inoperable at all due
to enhancements that require other OS improvements only present
in newer OS releases.

I do not recommend installing Fedora Core developmental XFree86
binary rpms on a Fedora Core 1 system.  I recommend instead if
one wishes to do that, to upgrade to the latest Fedora Core
test relesae and then upgrade to current rawhide bits, that way
the package is running in the environment it was compiled for.

That said, you may find that the binaries do actually work in
Fedora Core 1 perhaps, but if so, it is just luck and not something
intentionally or guaranteed to always happen.  ;o)

Nothing has changed in the radeon driver for quite a while, and
since I'm replacing 4.3.0 with Xorg X11 in Fedora Core devel
soon, there are no planned radeon updates for 4.3.0 for quite some
time in the future at least at the current time.

Hope this helps.
Comment 12 Jason Tibbitts 2004-08-27 14:27:30 EDT
No problem at all with these cards in FC2 and beyond, so I'll close
this bug out.

Note You need to log in before you can comment on or make changes to this bug.