Bug 1081581 - Modular Kernel Packaging for Cloud
Summary: Modular Kernel Packaging for Cloud
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking   
(Show other bugs)
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Reznik
QA Contact:
Pete Travis
URL:
Whiteboard: ChangeAcceptedF21 SystemWideChange
Keywords:
Depends On: 1074522
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-27 15:53 UTC by Jaroslav Reznik
Modified: 2014-12-08 15:22 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-08 15:22:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pbokoc: fedora_requires_release_note+


Attachments (Terms of Use)

Description Jaroslav Reznik 2014-03-27 15:53:04 UTC
This is a tracking bug for Change: Modular Kernel Packaging for Cloud
For more details, see: http://fedoraproject.org//wiki/Changes/Modular_Kernel_Packaging_for_Cloud

Kernel modules that are not necessary in virtualized environments become optionally (un)installable.

Comment 1 Josh Boyer 2014-04-29 14:44:14 UTC
I plan on committing the kernel.spec changes for this later today.  If for some reason people aren't ready for that, please let me know.

Comment 2 Sandro Mathys 2014-05-05 13:22:11 UTC
Change is substantially done and testable.

On a side note, the naming scheme changed a bit after discussion on the fedora kernel list. Since we already had kernel-modules-extra, it was requested to call the proposed kernel-drivers package kernel-modules instead.

Comment 3 Pete Travis 2014-09-23 05:01:31 UTC
Draft release notes are available for review at https://fedoraproject.org/wiki/Documentation_Kernel_Beat#Modular_Kernel_Packaging . We'll boast about it in the Cloud section too, of course, but probably with less detail and in a different context.


Note You need to log in before you can comment on or make changes to this bug.