Bug 1081583 - Optional Javadocs
Optional Javadocs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
Eduardo Mayorga
ChangeAcceptedF21 SystemWideChange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-27 11:59 EDT by Jaroslav Reznik
Modified: 2014-12-08 10:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-08 10:22:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pbokoc: fedora_requires_release_note+


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2014-03-27 11:59:28 EDT
This is a tracking bug for Change: Optional Javadocs
For more details, see: http://fedoraproject.org//wiki/Changes/OptionalJavadocs

Make javadoc subpackages of Java packages optional in guidelines and communicate this change to users.
Comment 1 Jaroslav Reznik 2014-07-04 06:43:37 EDT
This message is a reminder that Fedora 21 Accepted Changes Freeze Deadline is on 2014-07-08 [1].

At this point, all accepted Changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be so enabled at Change Freeze.

This bug should be set to the MODIFIED state to indicate that it achieved completeness. Status will be provided to FESCo right after the deadline. If, for any reasons, your Change is not in required state, let me know and we will try to find solution. For Changes you decide to cancel/move to the next release, please use the NEW status and set needinfo on me and it will be acted upon. 

In case of any questions, don't hesitate to ask Wrangler (jreznik). Thank you.

[1] https://fedoraproject.org/wiki/Releases/21/Schedule
Comment 2 Jaroslav Reznik 2014-10-07 08:23:44 EDT
This message is a reminder that Fedora 21 Change Checkpoint: 100% Code Complete Deadline (Former Accepted Changes 100% Complete) is on 2014-10-14 [1].

All Accepted Changes has to be code complete and ready to be validated in the Beta release (optionally by Fedora QA). Required bug state at this point is ON_QA.

As for several System Wide Changes, Beta Change Deadline is a point of contingency plan. All incompleted Changes will be reported to FESCo on 2014-10-15 meeting. In case of any questions, don't hesitate to ask Wrangler (jreznik).

[1] https://fedoraproject.org/wiki/Releases/21/Schedule
Comment 3 Stanislav Ochotnicky 2014-10-13 07:33:00 EDT
As noted in http://fedoraproject.org//wiki/Changes/OptionalJavadocs this feature requires a release notes.  The guideline change has already been approved (just wiki text hasn't been updated since then). Some java packages already don't have javadocs
Comment 4 Petr Bokoc 2014-10-14 08:05:01 EDT
Hi Stando, thanks for writing the note. We already had this change mentioned in the working version of the RNs, so I added your text to it. 

You can now find the release note at https://fedoraproject.org/wiki/Documentation_Java_Beat. If you would like to make any additional changes to the note, please contact the docs@fedoraproject.org mailing list, or ask in #fedora-docs on FreeNode. Making changes to the Wiki page at this point does not guarantee that these changes will appear in the final version.
Comment 5 Jaroslav Reznik 2014-10-15 07:29:40 EDT
As this change is about guidelines and guidelines are approved, documentation is created, moving to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.