Bug 1081753 - do not emit uncaught exceptions from automatic makecache runs
do not emit uncaught exceptions from automatic makecache runs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:3a44f27452677904342a0091083...
:
: 1085020 1087566 1092851 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-27 17:21 EDT by Martin
Modified: 2014-09-14 20:04 EDT (History)
8 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.0.8-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-31 19:57:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (6.62 KB, text/plain)
2014-03-27 17:21 EDT, Martin
no flags Details
File: environ (72 bytes, text/plain)
2014-03-27 17:21 EDT, Martin
no flags Details

  None (edit)
Description Martin 2014-03-27 17:21:15 EDT
Version-Release number of selected component:
dnf-0.4.19-1.fc20

Additional info:
reporter:       libreport-2.2.0
cmdline:        /usr/bin/python /usr/bin/dnf -v makecache timer
executable:     /usr/bin/dnf
kernel:         3.13.6-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
#1 <module> in /usr/lib/python2.7/site-packages/dnf/cli/__init__.py:30
#2 <module> in /usr/bin/dnf:34
Comment 1 Martin 2014-03-27 17:21:20 EDT
Created attachment 879660 [details]
File: backtrace
Comment 2 Martin 2014-03-27 17:21:22 EDT
Created attachment 879661 [details]
File: environ
Comment 3 Ales Kozumplik 2014-03-28 04:26:32 EDT
I think 'makecache timer' ran at the exact moment when dnf was being upgraded. Martin, what does 'dnf -v makecache timer' produce when run from a terminal as a root?

Thank you.
Comment 4 Ales Kozumplik 2014-04-07 13:14:14 EDT
*** Bug 1085020 has been marked as a duplicate of this bug. ***
Comment 5 Ales Kozumplik 2014-04-24 06:45:18 EDT
*** Bug 1087566 has been marked as a duplicate of this bug. ***
Comment 6 Ales Kozumplik 2014-04-24 08:14:25 EDT
Abrt reporting of the DNF runs from systemd timer are disabled starting with 1dff00a.
Comment 7 Ales Kozumplik 2014-04-30 02:27:43 EDT
*** Bug 1092851 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2014-05-02 04:33:13 EDT
dnf-0.5.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.5.1-1.fc20
Comment 9 Fedora Update System 2014-05-02 17:05:45 EDT
Package dnf-0.5.1-1.fc20, hawkey-0.4.14-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.5.1-1.fc20 hawkey-0.4.14-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-5937/hawkey-0.4.14-1.fc20,dnf-0.5.1-1.fc20
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2014-05-28 08:09:29 EDT
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20
Comment 11 Fedora Update System 2014-05-28 19:49:26 EDT
Package dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.0.8-2.fc20 libsolv-0.6.1-1.git6d968f1.fc20 hawkey-0.4.16-1.fc20 dnf-0.5.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6789/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2014-05-31 19:57:58 EDT
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.