Bug 1082026 - 'unknown object' thrown where 'object exists' is expected
Summary: 'unknown object' thrown where 'object exists' is expected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-tools
Version: Development
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: 3.1
: ---
Assignee: Gordon Sim
QA Contact: Michal Toth
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-28 13:53 UTC by Petr Matousek
Modified: 2015-04-14 13:47 UTC (History)
4 users (show)

Fixed In Version: qpid-tools-0.30-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-14 13:47:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-5705 None None None Never
Red Hat Product Errata RHEA-2015:0805 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.1 Release 2015-04-14 17:45:54 UTC

Description Petr Matousek 2014-03-28 13:53:19 UTC
Description of problem:

'unknown object type: domain' exception is reported instead of 'object already exists: new_domain' exception by qpid-config when creating already existing domain.

Version-Release number of selected component (if applicable):
qpid-cpp-*-0.22-36
qpid-tools-0.22-9

How reproducible:
100%

Steps to Reproduce:
1. qpid-config  add domain new_domain --argument url=<broker_url> 
2. repeat step 1.
3. 'unknown object type: domain'

Actual results:
'unknown object type: domain' exception

Expected results:
'object already exists: new_domain' exception

Additional info:
# qpid-config  add domain new_domain --argument url=<broker_url>
# qpid-config  add domain new_domain --argument url=<broker_url>
Failed: Exception: Exception from Agent: {u'error_code': 7, u'error_text': 'unknown object type: domain'}

Comment 1 Gordon Sim 2014-04-16 19:31:52 UTC
Fixed upstream: https://svn.apache.org/r1587999

Comment 3 Michal Toth 2014-10-21 08:23:26 UTC
Expected exception message is thrown. 
Verified on 
qpid-tools-0.30-1
qpid-cpp-*-0-30-2

Comment 5 errata-xmlrpc 2015-04-14 13:47:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0805.html


Note You need to log in before you can comment on or make changes to this bug.