Bug 1082027 - Missing domain info when listing incoming/outgoing links
Summary: Missing domain info when listing incoming/outgoing links
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-tools
Version: Development
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: 3.1
: ---
Assignee: Gordon Sim
QA Contact: Eric Sammons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-28 13:55 UTC by Petr Matousek
Modified: 2015-04-14 13:47 UTC (History)
3 users (show)

Fixed In Version: qpid-tools-0.30-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-14 13:47:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-5706 None None None Never
Red Hat Product Errata RHEA-2015:0805 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.1 Release 2015-04-14 17:45:54 UTC

Description Petr Matousek 2014-03-28 13:55:54 UTC
Description of problem:

Incoming/outgoing domain links listing do not provide any relation data (domain reference/url) to the interconnected domains. There is no possibility to found out to which domain the link is connected.

# qpid-config list outgoing
Objects of type 'outgoing'
  name           sessionRef      target  source  transfers  containerid
  =======================================================================
  outgoing-link  0x7f3164004d40  target  source  0          

listing domain do not offer any info about domain links as well.

# qpid-config list domain
Objects of type 'domain'
  name        username  url                         durable  mechanisms  password
  =================================================================================
  dst_broker            amqp:tcp:10.34.37.166:5672  False    ANONYMOUS


Note: by listing the qmf data of domain/link objects I don't see any shared data, so I'm wondering if it's somehow feasible at all. See additional info for details.

Version-Release number of selected component (if applicable):
qpid-cpp-*-0.22-36
qpid-tools-0.22-9

How reproducible:
100%

Steps to Reproduce:
1. qpid-config list outgoing (or incoming)
2. no domain info listed

Actual results:
no info about domain when listing incoming/outgoing links

Expected results:
listing of incoming/outgoing links provide info about the interconnected domain

Additional info:

# ./qmf2_list_objects --query-data 'outgoing' | ipython
{'outgoing-link': {'_create_ts': 1396009780915094979,
  '_delete_ts': 0,
  '_object_id': {'_agent_epoch': 17,
   '_object_name': 'org.apache.qpid.broker:outgoing:,outgoing-link'},
  '_schema_id': {'_class_name': 'outgoing',
   '_hash': '03618794-f561-5223-982d-b478eda9db48',
   '_package_name': 'org.apache.qpid.broker',
   '_type': '_data'},
  '_update_ts': 1396009789208168918,
  'containerid': None,
  'name': 'outgoing-link',
  'sessionRef': {'_agent_epoch': 17,
   '_object_name': 'org.apache.qpid.broker:session:0x7f3164004d40'},
  'source': 'source',
  'target': 'target',
  'transfers': 0}}

# ./qmf2_list_objects --query-data 'domain' | ipython 
{'dst_broker': {'_create_ts': 1396009735337795595,
  '_delete_ts': 0,
  '_object_id': {'_agent_epoch': 17,
   '_object_name': 'org.apache.qpid.broker:domain:dst_broker'},
  '_schema_id': {'_class_name': 'domain',
   '_hash': 'dd2e72ca-09d2-64c6-ff47-38a29b5ebee4',
   '_package_name': 'org.apache.qpid.broker',
   '_type': '_data'},
  '_update_ts': 1396009739208265735,
  'durable': False,
  'mechanisms': 'ANONYMOUS',
  'name': 'dst_broker',
  'password': None,
  'url': 'amqp:tcp:10.34.37.166:5672',
  'username': None}}

Comment 1 Gordon Sim 2014-04-16 19:30:56 UTC
Fixed upstream: https://svn.apache.org/r1588000

Comment 3 Valiantsina Hubeika 2014-10-20 19:53:37 UTC
verified on
qpid-tools-0.30-1.el6.noarch

Comment 6 errata-xmlrpc 2015-04-14 13:47:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0805.html


Note You need to log in before you can comment on or make changes to this bug.