Bug 108205 - Up2date fails to install rpms
Up2date fails to install rpms
Status: CLOSED DUPLICATE of bug 108454
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-28 11:20 EST by Paul F. Johnson
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2003-10-28 11:20:33 EST
Description of problem:
After downloading the rpms for installing, up2date just sits there with the
hourglass rotating. Nothing installs. It seems that up2date is causing a hang
with rpm as well as attempts to install manually will check dependancies,
install up to 100% of the first package, but not complete.

Version-Release number of selected component (if applicable):
4.1.12

How reproducible:
Always

Steps to Reproduce:
1. Set to update, download rpms
2. Click to install. Wait, wait, wait some more, kill up2date
3. Attempt to install from the terminal
    
Actual results:
A reset is required to install any rpms, up2date does not install the downloaded
rpms

Expected results:
Everything should be happy and rpms install

Additional info:
Comment 1 Larry Maddox 2003-10-29 11:52:56 EST
i ran up2date with similar results.  when running from the command line with
--nox --nosig options, the following error messages were produced:

----------------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1187, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 765, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1050, in batchRun
    batch.run()
  File "up2dateBatch.py", line 82, in run
  File "up2dateBatch.py", line 153, in __installPackages
  File "up2date.py", line 604, in installPackages
  File "up2date.py", line 173, in getRealHeader
rpm.error: public key not trusted
-------------------------------------------------------------------------

i tracked a problem with a couple of other rpm's.  i was able to all but 2 of
the download rpm's by hand.  they are redhat-config-network-1.3.10-1 and
redhat-config-network-tui-1.3.10-1.  i don't know if this the problem, but it
might make the up2date problem worse.

lam
Comment 2 Andrew 2003-10-29 14:51:27 EST
Seems like the problem is with those 2 RPMs:

[root@localhost up2date]# rpm -Uvh redhat-config-network*.rpm
error: open of <!DOCTYPE failed: No such file or directory
error: open of HTML failed: No such file or directory
error: open of PUBLIC failed: No such file or directory
 
Reran up2date from the Terminal without any args and deselected
"redhat-config-network-1.3.10-1.noarch.rpm" and
"redhat-config-network-tui-1.3.10-1.noarch.rpm"

and life is good again:

The Red Hat Update Agent has finished installing
 the following packages successfully:

kernel-2.4.22-1.2111.nptl
kernel-source-2.4.22-1.2111.nptl
bash-2.05b-31
evolution-1.4.5-7
fedora-release-1-1
gzip-1.3.3-11
initscripts-7.42-1
kdebase-3.1.4-6
libgnomeprint22-2.4.0-1
libgnomeprintui22-2.4.0-1
libtool-1.5-8
libtool-libs-1.5-8
metacity-2.6.3-1
nautilus-2.4.0-7
ntp-4.2.0-2
prelink-0.3.0-13
redhat-artwork-0.87-1
sendmail-8.12.10-1.1.1



BTW: These version seem to run really well now with regards to speed.  Just need
to fix the wrong filesize problem (see Bugzilla Bug# 107048).  Bug# 108454,
108191 also detail similar problems and may be useful to others.

$ rpm -q up2date
up2date-4.1.12-1
$ rpm -q up2date-gnome
up2date-gnome-4.1.12-1
$ rpm -q gpg-pubkey
gpg-pubkey-db42a60e-37ea5438
gpg-pubkey-897da07a-3c979a7f
$ rpm -q rpm
rpm-4.2.1-0.30
$ rpm -q yum
yum-2.0.4-1

-------------------------------------------------------------------------
Comment 3 Barry K. Nathan 2003-10-29 15:57:57 EST
possibly a dupe of bug 108191
Comment 4 Adrian Likins 2004-01-16 15:22:08 EST

*** This bug has been marked as a duplicate of 108454 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:59:29 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.