Bug 10821 - broken file glob
Summary: broken file glob
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-14 15:36 UTC by jpeek
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-02 14:27:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jpeek 2000-04-14 15:36:30 UTC
ls [A-Z]* seems to match independently of case with the shipped zsh

Interestingly ls [A-B]* does not macth b* but [A-C]* or [B-Z]* does.

Installed zsh.3.1.6 which seems to fix it, but this is probably beta zsh

Lost a bunch of file using this, hopefully I had backups.

Comment 1 Trond Eivind Glomsrxd 2000-04-17 17:29:59 UTC
I've confirmed the bug and reported it to the zsh-team - and will try to find
it.

Comment 2 Trond Eivind Glomsrxd 2000-04-18 16:35:59 UTC
The problem is that when using a locale, A < a < B. This doesn't only affect
zsh, but also bash2. I'm not sure about what to do with it - explicitly
unsetting LC_COLLATE (setting it to POSIX, perhaps) in the program might be one
solution, but what side effects would that have?

Comment 3 Trond Eivind Glomsrxd 2000-04-18 18:39:59 UTC
The glibc way of sorting doesn't make sense

Comment 4 Jakub Jelinek 2000-08-24 07:41:13 UTC
This has changed recently, both fnmatch/glob and regex should behave more
sanely


Note You need to log in before you can comment on or make changes to this bug.