Bug 1082154 (CVE-2014-2669) - CVE-2014-2669 postgresql: multiple integer overflows in hstore_io.c
Summary: CVE-2014-2669 postgresql: multiple integer overflows in hstore_io.c
Alias: CVE-2014-2669
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
Depends On: 1065845 1069071 1069072
Blocks: 1065240 1095075
TreeView+ depends on / blocked
Reported: 2014-03-28 20:23 UTC by Vincent Danen
Modified: 2019-09-29 13:15 UTC (History)
4 users (show)

Fixed In Version: postgresql 9.0.16, postgresql 9.1.12, postgresql 9.2.7, postgresql 9.3.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2015-02-26 23:10:22 UTC

Attachments (Terms of Use)

System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2014:0469 normal SHIPPED_LIVE Important: cfme security, bug fix, and enhancement update 2014-05-12 22:12:35 UTC

Description Vincent Danen 2014-03-28 20:23:16 UTC
Common Vulnerabilities and Exposures assigned an identifier CVE-2014-2669 to
the following vulnerability:

Name: CVE-2014-2669
URL: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-2669
Assigned: 20140328
Reference: http://wiki.postgresql.org/wiki/20140220securityrelease
Reference: http://www.postgresql.org/about/news/1506/
Reference: http://www.postgresql.org/support/security/
Reference: https://github.com/postgres/postgres/commit/31400a673325147e1205326008e32135a78b4d8a
Reference: DEBIAN:DSA-2864
Reference: http://www.debian.org/security/2014/dsa-2864
Reference: DEBIAN:DSA-2865
Reference: http://www.debian.org/security/2014/dsa-2865

Multiple integer overflows in contrib/hstore/hstore_io.c in PostgreSQL
9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and
9.3.x before 9.3.3 allow remote authenticated users to have
unspecified impact via vectors related to the (1) hstore_recv, (2)
hstore_from_arrays, and (3) hstore_from_array functions in
contrib/hstore/hstore_io.c; and the (4) hstoreArrayToPairs function in
contrib/hstore/hstore_op.c, which triggers a buffer overflow.  NOTE:
this issue was SPLIT from CVE-2014-0064 because it has a different set
of affected versions.

Comment 1 Vincent Danen 2014-03-28 20:31:17 UTC
See bug #1065230 for details on CVE-2014-0064.  Because both Red Hat Enterprise Linux 5 and 6 do not ship with PostgreSQL 9.x, they are not affected by this flaw.


Not vulnerable. This issue did not affect the versions of PostgreSQL as shipped with Red Hat Enterprise Linux 5 and 6.


Red Hat would like to thank the PostgreSQL project for reporting this issue. Upstream acknowledges Heikki Linnakangas and Noah Misch as the original reporters.

Comment 2 Vincent Danen 2014-03-28 20:50:05 UTC
This issue has been addressed in following products:

  Red Hat Software Collections for RHEL-6

Via RHSA-2014:0221 https://rhn.redhat.com/errata/RHSA-2014-0221.html

Comment 4 errata-xmlrpc 2014-05-12 18:18:29 UTC
This issue has been addressed in following products:

  CloudForms Management Engine 5.x

Via RHSA-2014:0469 https://rhn.redhat.com/errata/RHSA-2014-0469.html

Note You need to log in before you can comment on or make changes to this bug.