Bug 1082229 - Cannot log in to KDE after yum update
Summary: Cannot log in to KDE after yum update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sddm
Version: 20
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-29 11:39 UTC by Edvard Fagerholm
Modified: 2014-10-07 09:28 UTC (History)
11 users (show)

Fixed In Version: sddm-0.2.0-0.31.20140627gitf49c2c79.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-30 10:30:21 UTC


Attachments (Terms of Use)
dmesg (69.86 KB, text/plain)
2014-03-29 11:53 UTC, Edvard Fagerholm
no flags Details
Xorg log (24.21 KB, text/x-log)
2014-03-29 11:54 UTC, Edvard Fagerholm
no flags Details

Description Edvard Fagerholm 2014-03-29 11:39:06 UTC
Description of problem:

After running yum update today I'm unable to log in on the Fedora 20 KDE spin. When KDE's login window pops up, I can type in my username and password, but when I press enter in the password window nothing happens.

If I click on the ">" button same problem. Clicking on the "shutdown" or "restart buttons also does nothing. When I click on the buttons their color change while I hold down the left mouse button, so at least KDE is registering the key press.

I can't see anything in any logs, so I'm not sure if if there is any more useful information that I can provide.

How reproducible:

Always

Steps to Reproduce:
1. Start computer.
2. Wait for login screen to appear.
3. Try to log in.

Comment 1 Edvard Fagerholm 2014-03-29 11:53:51 UTC
Created attachment 880119 [details]
dmesg

Comment 2 Edvard Fagerholm 2014-03-29 11:54:31 UTC
Created attachment 880120 [details]
Xorg log

Comment 3 Edvard Fagerholm 2014-03-29 12:15:55 UTC
Switching login manager to slim allows me to login, so the problem is not in KDE, but somewhere in sddm or its related packages. Someone that better understands the graphical login sequence can probably fix the bug report to match the right package.

Comment 4 Kevin Kofler 2014-03-29 23:31:17 UTC
The default login manager on F20 KDE is KDM, not SDDM, so are you sure you were using SDDM?

Comment 5 Edvard Fagerholm 2014-03-30 12:54:12 UTC
I looked into this a bit. I only reboot the computer maybe once a month and yesterday when I rebooted it due to a power failure, it seemed like the login screen had changed slightly. Looks like this is because the login manager was changed to sddm from kdm.

I haven't installed any new software since installing the machine in January and I've only ran "yum update" every few days or so. It seems like some update must have pulled in sddm as a dependency at some point. I haven't touched systemctl for anything at all except enabling sshd during installation, so I'm a bit mystified how the login manager could have changed.

Anyway, it looks like the bug report is about sddm.

Comment 6 Fedora Update System 2014-06-25 11:09:01 UTC
sddm-0.2.0-0.29.20140623gitdb1d7381.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sddm-0.2.0-0.29.20140623gitdb1d7381.fc20

Comment 7 Fedora Update System 2014-06-25 11:13:09 UTC
sddm-0.2.0-0.29.20140623gitdb1d7381.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sddm-0.2.0-0.29.20140623gitdb1d7381.fc19

Comment 8 Fedora Update System 2014-06-26 01:57:03 UTC
Package sddm-0.2.0-0.29.20140623gitdb1d7381.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sddm-0.2.0-0.29.20140623gitdb1d7381.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7749/sddm-0.2.0-0.29.20140623gitdb1d7381.fc19
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2014-06-30 10:30:21 UTC
sddm-0.2.0-0.31.20140627gitf49c2c79.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-10-07 09:28:51 UTC
sddm-0.9.0-1.20141007git6a28c29b.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sddm-0.9.0-1.20141007git6a28c29b.fc19


Note You need to log in before you can comment on or make changes to this bug.