Bug 1082230 - TypeError in dnf history info <id>
TypeError in dnf history info <id>
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
: 1084434 1085276 (view as bug list)
Depends On:
Blocks: 1085680
  Show dependency treegraph
 
Reported: 2014-03-29 07:52 EDT by Tim Lauridsen
Modified: 2014-05-31 19:59 EDT (History)
9 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.0.8-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-14 18:48:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Lauridsen 2014-03-29 07:52:08 EDT
Description of problem:

dnf history gives at TypeError traceback

Version-Release number of selected component (if applicable):
0.4.19

How reproducible:
every time

Steps to Reproduce:
1. sudo dnf history info <id>
2.
3.

Actual results:
sudo dnf history info 1031
Transaction ID : 1031
Begin time     : Sat Mar 29 11:24:45 2014
Begin rpmdb    : 1770:da6e27bfd29d785e54e56383fb35b10aa2b311f5
End time       :            11:24:49 2014 (4 seconds)
End rpmdb      : 1778:59a951f83af2f29a29555c0acf3b6db438bb55cc
User           : tim <tim>
Return-Code    : Success
Command Line   : install yumex-dnf
Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 242, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 75, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 124, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1378, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands/__init__.py", line 2280, in run
    ret = self.output.historyInfoCmd(extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 1810, in historyInfoCmd
    self._historyInfoCmd(tid, pats)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 1931, in _historyInfoCmd
    if not isinstance(old.tid):
TypeError: isinstance expected 2 arguments, got 1


Expected results:
 No errors

Additional info:
Comment 1 Ales Kozumplik 2014-03-31 02:31:55 EDT
Moving to Radek.
Comment 2 Tim Lauridsen 2014-04-02 06:07:19 EDT
I have submitted a fix here.

https://github.com/akozumpl/dnf/pull/117
Comment 3 Ales Kozumplik 2014-04-04 07:48:31 EDT
*** Bug 1084434 has been marked as a duplicate of this bug. ***
Comment 4 ILMostro 2014-04-05 16:16:41 EDT
I've been grappling with this for a number of days now; dnf-0.4.19-1.noarch is installed, but I don't recall when this started.  Is this an issue on "all" systems or is it specific to some dependency/misconfiguration on "some" systems? Mainly, should we expect an official release-version to fix this some time in the near future or will we have to pull the git repository? From the looks of it, `isinstance` expects tid AND pats, as opposed to OR; I suppose it may be coding error (i.e. system-wide).
Comment 5 Francisco de la Peña 2014-04-06 01:28:58 EDT
*** Bug 1084727 has been marked as a duplicate of this bug. ***
Comment 6 Tim Lauridsen 2014-04-07 00:52:57 EDT
This isssue should happen on all systems where you are using the the 'history info " command.
I dont know when 0.5.0 there will contain the fix is released.

there is daily builds here:
http://jenkins.cloud.fedoraproject.org/job/DNF/lastSuccessfulBuild/artifact/fedora-20-x86_64-build/

you can try out.
Comment 7 Fedora Update System 2014-04-07 08:14:23 EDT
dnf-0.4.20-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.20-1.fc20
Comment 8 Ales Kozumplik 2014-04-08 07:10:29 EDT
*** Bug 1085276 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2014-04-08 20:52:14 EDT
Package dnf-0.4.20-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.20-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4882/dnf-0.4.20-1.fc20
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2014-04-14 18:48:33 EDT
dnf-0.4.20-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2014-05-02 04:32:45 EDT
dnf-0.5.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.5.1-1.fc20
Comment 12 Fedora Update System 2014-05-28 08:10:37 EDT
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20
Comment 13 Fedora Update System 2014-05-31 19:59:12 EDT
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.