Bug 1082364 - Require glibc-devel
Summary: Require glibc-devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pocl
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabian Deutsch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-30 19:39 UTC by Fabian Deutsch
Modified: 2014-04-26 09:18 UTC (History)
3 users (show)

Fixed In Version: pocl-0.9-4.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-26 09:18:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Fabian Deutsch 2014-03-30 19:39:14 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Michael Schwendt 2014-03-30 19:53:20 UTC
Please don't add a dependency on glibc-devel anywhere.

"gcc" (and its dep on glibc-devel) is part of Fedora's minimum build environment as well as the "C Development Tools and Libraries" repo group (yum grouplist):

https://fedoraproject.org/wiki/Packaging:Guidelines#Exceptions_2

Comment 2 Fedora Update System 2014-04-01 09:11:42 UTC
pocl-0.9-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pocl-0.9-3.fc19

Comment 3 Fedora Update System 2014-04-01 09:11:50 UTC
pocl-0.9-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pocl-0.9-3.fc20

Comment 4 Michael Schwendt 2014-04-01 11:06:37 UTC
| http://pkgs.fedoraproject.org/cgit/pocl.git/commit/?id=fd215c27a880e3e58a36c5489e086657fcaf43af
|
| +# libstdc++ from gcc is used
| # https://bugzilla.redhat.com/show_bug.cgi?id=1021645
| Requires: gcc-c++
|
| +# Runtime dependency, because libm.so is required for kernels
| +Requires: glibc-devel
| +

The added comments don't make much sense either for the same reason pointed out in the bodhi ticket.

If you wanted to "fix" anything, it would be plausible to add %_isa to the explicit Requires to make them arch-specific:

  https://fedoraproject.org/wiki/Packaging:Guidelines#Requires_2

Comment 5 Fedora Update System 2014-04-02 09:10:58 UTC
Package pocl-0.9-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pocl-0.9-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4628/pocl-0.9-3.fc20
then log in and leave karma (feedback).

Comment 6 Fabian Deutsch 2014-04-04 07:24:48 UTC
(In reply to Michael Schwendt from comment #4)
> |
> http://pkgs.fedoraproject.org/cgit/pocl.git/commit/
> ?id=fd215c27a880e3e58a36c5489e086657fcaf43af
> |
> | +# libstdc++ from gcc is used
> | # https://bugzilla.redhat.com/show_bug.cgi?id=1021645
> | Requires: gcc-c++
> |
> | +# Runtime dependency, because libm.so is required for kernels
> | +Requires: glibc-devel
> | +
> 
> The added comments don't make much sense either for the same reason pointed
> out in the bodhi ticket.
> 
> If you wanted to "fix" anything, it would be plausible to add %_isa to the
> explicit Requires to make them arch-specific:
> 
>   https://fedoraproject.org/wiki/Packaging:Guidelines#Requires_2

Hey Michael,

thanks for htis reply - always nice if people care :)

Well, on a Fresh F20 system I  only noticed that the unversioned libm.so was missing, even that pocl (and thus gcc-c++, which should hav pulled in glibc-devel according to your comment) was installed.

I did not look up the dependency chain, but will do investigate this further now.

Comment 7 Fabian Deutsch 2014-04-07 07:52:09 UTC
Michael,

you were right in the bodhi ticket, the requirements are redundant.
What I wonder about is why I had to manually install glibc-devel.

Comment 8 Michael Schwendt 2014-04-07 08:14:45 UTC
If you haven't examined the issue, it's probably too late now to query the RPM database.

You could retry it with a fresh installation (or "yum history undo …" or removing pocl and packages to restart from a rather "clean" installation).

Just as one theory: The dependencies in gcc-c++ and gcc are not arch-specific [yet],

  $ rpm -qR gcc-c++|grep ^g
  gcc = 4.8.2-7.fc20
  $ rpm -qR gcc|grep ^g
  glibc-devel >= 2.2.90-12

so on multi-arch platforms like x86_64 it can happen that temporary dependency problems lead to pulling in the i686 packages to satisfy dependencies. *And* if glibc-devel.i686 has been installed before, it would make the depsolver happy, too.

Comment 9 Fedora Update System 2014-04-15 15:41:44 UTC
Package pocl-0.9-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pocl-0.9-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4666/pocl-0.9-4.fc19
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2014-04-26 09:18:25 UTC
pocl-0.9-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.