Bug 1082400 - Release has dependency on non-packaged rednose
Summary: Release has dependency on non-packaged rednose
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-sure
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bohuslav "Slavek" Kabrda
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1036755
TreeView+ depends on / blocked
 
Reported: 2014-03-31 00:48 UTC by Jamie Lennox
Modified: 2015-10-26 01:12 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-06-03 21:57:59 UTC


Attachments (Terms of Use)

Description Jamie Lennox 2014-03-31 00:48:17 UTC
The library now has a dependency on the rednose component which it for some reason declares as a runtime dependency. 

https://github.com/gabrielfalcao/sure/blob/master/requirements.txt

Neither nose nor rednose are actual runtime dependencies of the project - and IMO rednose should not be considered a dep at all (as it just provides highlighting for nosetests results).

He also requires very specific versions of the dependencies: 
nose==1.3.0
rednose==0.4.1
which i have seen from him before as a way to manage the travis-ci environments but is not something we want to enforce in the distro packages. 

I think this should be patched in the RPM to remove the all the setuptools dependencies of the project and I'l see if i can get him to fix it upstream.

Comment 1 Jamie Lennox 2014-03-31 01:37:06 UTC
Upstream PR: https://github.com/gabrielfalcao/sure/pull/57

Comment 2 Fedora Update System 2014-03-31 11:37:50 UTC
python-sure-1.2.5-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-sure-1.2.5-2.el6

Comment 3 Bohuslav "Slavek" Kabrda 2014-03-31 11:38:38 UTC
Fixed in rawhide and epel 6. Thanks for the patch:

python-sure-1.2.5-2.fc21
python-sure-1.2.5-2.el6

Comment 4 Fedora Update System 2014-03-31 18:24:49 UTC
Package python-sure-1.2.5-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing python-sure-1.2.5-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-1018/python-sure-1.2.5-2.el6
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-06-03 21:57:59 UTC
python-sure-1.2.5-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.