Bug 1082447 - ifup p1p2 failed due to the existing p1p2.200 device
Summary: ifup p1p2 failed due to the existing p1p2.200 device
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initscripts
Version: 7.0
Hardware: All
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-31 05:54 UTC by Xiaowei Li
Modified: 2021-03-01 07:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-01 07:32:25 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Xiaowei Li 2014-03-31 05:54:11 UTC
Description of problem:



Version-Release number of selected component (if applicable):
initscripts-9.49.15-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. configre the vlan device on p1p2. ( actually it's the fcoe vlan device )
p1p2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::21b:21ff:fe3f:a1b5  prefixlen 64  scopeid 0x20<link>
        inet6 fd00:abcd::21b:21ff:fe3f:a1b5  prefixlen 64  scopeid 0x0<global>
        ether 00:1b:21:3f:a1:b5  txqueuelen 1000  (Ethernet)
        RX packets 239303  bytes 230794665 (220.1 MiB)
        RX errors 0  dropped 13  overruns 0  frame 0
        TX packets 52217  bytes 72395120 (69.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

p1p2.200: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::21b:21ff:fe3f:a1b5  prefixlen 64  scopeid 0x20<link>
        ether 00:1b:21:3f:a1:b5  txqueuelen 0  (Ethernet)
        RX packets 40137  bytes 26515150 (25.2 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 67  bytes 2926 (2.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


2. ifup p1p2

[root@storageqe-51 ~]# ifup p1p2
DEBUG: CONFIG=p1p2
DEVICE: DEVICE=p1p2
p1p2.200@p1p2
DEVICE: DEVICE=p1p2
p1p2.200@p1p2

p1p2 p1p2.200@p1p2
./network-functions: line 76: [: /etc/dhcp/dhclient-p1p2: binary operator expected
./network-functions: line 78: [: /etc/dhclient-p1p2: binary operator expected
./network-functions: line 66: [: /var/lib/dhclient/dhclient-p1p2: binary operator expected

Determining IP information for p1p2
p1p2.200@p1p2...p1p2.200@p1p2.lease: interface name too long (is 19)

This version of ISC DHCP is based on the release available
on ftp.isc.org.  Features have been added and other changes
have been made to the base software release in order to make
it work better with this distribution.

Please report for this software via the Red Hat Bugzilla site:
    http://bugzilla.redhat.com

exiting.
 failed.


3. but I can get the ip for p1p2 by dhclient p1p2

4. further debug message: 

if running bash -x ifup-eth ifcfg-p1p2 I can see the following debug information.

It means "get_device_by_hwaddr 00:1B:21:3F:A1:B5" will get p1p2 and p1p2.200, that's not expected since I only want to configure p1p2 not p1p2.200

++ get_device_by_hwaddr 00:1B:21:3F:A1:B5
++ LANG=C
++ ip -o link
++ awk -F ': ' -vIGNORECASE=1 '!/link\/ieee802\.11/ && /00:1B:21:3F:A1:B5/ { print $2 }'
+ DEVICE='p1p2
p1p2.200@p1p2'


Actual results:
fail to get ip for p1p2 by ifup and the network service failed to start due to this error.

Expected results:


Additional info:
workaround: dhclient p1p2

Comment 2 Xiaowei Li 2014-03-31 08:43:53 UTC
open to Intel since maybe they also hit the similar issue.

Comment 3 RHEL Program Management 2014-04-08 05:47:34 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 Lukáš Nykrýn 2014-06-18 10:57:19 UTC
Can you please attach you configuration?

Comment 5 Xiaowei Li 2014-08-12 05:57:59 UTC
(In reply to Lukáš Nykrýn from comment #4)
> Can you please attach you configuration?

here is my configuration.

p1p2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::21b:21ff:fe3f:a1b5  prefixlen 64  scopeid 0x20<link>
        inet6 fd00:abcd::21b:21ff:fe3f:a1b5  prefixlen 64  scopeid 0x0<global>
        ether 00:1b:21:3f:a1:b5  txqueuelen 1000  (Ethernet)
        RX packets 239303  bytes 230794665 (220.1 MiB)
        RX errors 0  dropped 13  overruns 0  frame 0
        TX packets 52217  bytes 72395120 (69.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

p1p2.200: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::21b:21ff:fe3f:a1b5  prefixlen 64  scopeid 0x20<link>
        ether 00:1b:21:3f:a1:b5  txqueuelen 0  (Ethernet)
        RX packets 40137  bytes 26515150 (25.2 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 67  bytes 2926 (2.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

I hit this issue when testing FCoE, but I think you can reproduce it when just create some vlan device.

Comment 6 Lukáš Nykrýn 2014-08-12 07:23:14 UTC
I was mentioning the /etc/sysconfig/network-scripts/ifcfg-* files.

Comment 7 Xiaowei Li 2014-08-14 09:38:55 UTC
(In reply to Lukáš Nykrýn from comment #6)
> I was mentioning the /etc/sysconfig/network-scripts/ifcfg-* files.

# cat ifcfg-p1p1
HWADDR=00:1B:21:3F:A1:B4
TYPE=Ethernet
BOOTPROTO=dhcp
DEFROUTE=yes
PEERDNS=yes
PEERROUTES=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_PEERDNS=yes
IPV6_PEERROUTES=yes
IPV6_FAILURE_FATAL=no
NAME=p1p1
UUID=21ce6dd3-d8dd-45cb-ac79-f7f5d8a3197d
ONBOOT=no

# cat ifcfg-p1p2
HWADDR="00:1B:21:3F:A1:B5"
TYPE="Ethernet"
BOOTPROTO="dhcp"
DEFROUTE="yes"
PEERDNS="yes"
PEERROUTES="yes"
IPV4_FAILURE_FATAL="no"
IPV6INIT="yes"
IPV6_AUTOCONF="yes"
IPV6_DEFROUTE="yes"
IPV6_PEERDNS="yes"
IPV6_PEERROUTES="yes"
IPV6_FAILURE_FATAL="no"
NAME="p1p2"
UUID="97c55a4f-0d8e-44ad-bb94-8f0ad051d898"
ONBOOT="yes"
NM_CONTROLLED="no"

[root@storageqe-51 network-scripts]# ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT qlen 1000
    link/ether 60:eb:69:d2:37:7a brd ff:ff:ff:ff:ff:ff
3: em2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether 60:eb:69:d2:37:7b brd ff:ff:ff:ff:ff:ff
4: p1p2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT qlen 1000
    link/ether 00:1b:21:3f:a1:b5 brd ff:ff:ff:ff:ff:ff
5: p1p2.200@p1p2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT 
    link/ether 00:1b:21:3f:a1:b5 brd ff:ff:ff:ff:ff:ff

[root@storageqe-51 network-scripts]# ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: em1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 60:eb:69:d2:37:7a brd ff:ff:ff:ff:ff:ff
    inet 10.66.86.55/23 brd 10.66.87.255 scope global dynamic em1
       valid_lft 41816sec preferred_lft 41816sec
    inet6 2620:52:0:4257:62eb:69ff:fed2:377a/64 scope global dynamic 
       valid_lft 2591966sec preferred_lft 2591966sec
    inet6 fe80::62eb:69ff:fed2:377a/64 scope link 
       valid_lft forever preferred_lft forever
3: em2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN qlen 1000
    link/ether 60:eb:69:d2:37:7b brd ff:ff:ff:ff:ff:ff
4: p1p2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:1b:21:3f:a1:b5 brd ff:ff:ff:ff:ff:ff
    inet6 fd00:abcd::21b:21ff:fe3f:a1b5/64 scope global dynamic 
       valid_lft 2591958sec preferred_lft 2591958sec
    inet6 fe80::21b:21ff:fe3f:a1b5/64 scope link 
       valid_lft forever preferred_lft forever
5: p1p2.200@p1p2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether 00:1b:21:3f:a1:b5 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::21b:21ff:fe3f:a1b5/64 scope link 
       valid_lft forever preferred_lft forever

Comment 8 Xiaowei Li 2014-08-14 09:39:34 UTC
[root@storageqe-51 network-scripts]# ls
ifcfg-em1    ifdown-eth     ifdown-sit       ifup-eth    ifup-ppp       init.ipv6-global
ifcfg-em2    ifdown-ippp    ifdown-Team      ifup-ippp   ifup-routes    network-functions
ifcfg-lo     ifdown-ipv6    ifdown-TeamPort  ifup-ipv6   ifup-sit       network-functions-ipv6
ifcfg-p1p1   ifdown-isdn    ifdown-tunnel    ifup-isdn   ifup-Team
ifcfg-p1p2   ifdown-post    ifup             ifup-plip   ifup-TeamPort
ifdown       ifdown-ppp     ifup-aliases     ifup-plusb  ifup-tunnel
ifdown-bnep  ifdown-routes  ifup-bnep        ifup-post   ifup-wireless

Comment 18 RHEL Program Management 2021-03-01 07:32:25 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.


Note You need to log in before you can comment on or make changes to this bug.