Bug 10825 - Upgrading 6.2 to 6.2 installs 112 MB
Upgrading 6.2 to 6.2 installs 112 MB
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-14 15:36 EDT by John Battista
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-17 11:35:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Battista 2000-04-14 15:36:34 EDT
After upgrading RH 6.0 to 6.2, subsequent boots from the CD-ROM and
repeating the upgrade process "upgrades" 112 MB of files including glibc,
kernel source code, and linuxconf everytime, no matter what.  Repeatable on
three machines so far...
Comment 1 Bill Nottingham 2000-04-17 11:18:59 EDT
This is the default behavior; an upgrade always upgrades
the 'Base' packages to the current package set to guarantee
a workable environment.

Perhaps this could be changed so that it doesn't upgrade
the exact same version on top of itself....
Comment 2 Jay Turner 2000-04-17 11:35:59 EDT
This is the intended bahavior so that a user can recover from a trashed system.
If we did not reinstall the base packages when the same version is already on
the system, then there would be no way to recover from corrupted version of
those files.  The intent is that once the user has prestine versions of the base
packages, then they can invoke RPM with the --force option to reinstall any
other corrupted packages.

Note You need to log in before you can comment on or make changes to this bug.