Bug 108255 - c.a.util.paramreter.ParameterRecord & RuntimeConfigLoader don't work with config loader tool
c.a.util.paramreter.ParameterRecord & RuntimeConfigLoader don't work with con...
Status: CLOSED WONTFIX
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-28 14:00 EST by Daniel Berrange
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-02 13:26:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2003-10-28 14:00:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
The classes com.arsdigita.util.parameter.ParameterRecord & RuntimeConfigLoader
don't work with config loader tool. Apps using these classes will get various
exceptions, not limited to NPEs, if they are loaded with 'ccm-conf init
[appname]'. These classes should be removed before their use becomes widespread
to eliminate future pain for developers.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to load an app using ParameterRecord instead of AbstractConfig
2.
3.
    

Additional info:
Comment 1 Daniel Berrange 2006-09-02 13:26:37 EDT
Closing old tickets

Note You need to log in before you can comment on or make changes to this bug.