Bug 108256 - Kickstart a asks for IP information twice.
Kickstart a asks for IP information twice.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-28 14:05 EST by Stephen John Smoogen
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-06 13:35:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2003-10-28 14:05:52 EST
Description of problem:

Have to do FTP install of various servers, and have found that the kickstart
asks for IP address information twice when the old line of 

network --bootproto=query 

is given. It asks for an IP address, and then does a Dynamic search for an IP
address again. It then goes again to the asking for an IP address and this time
it takes it and begins the install..

I notice that the manual only covers STATIC,BOOTP,TFTP as the bootquery modes,
but we arent able to run the last two in some of our areas. So I am guessing
that I am running into some bug when it cant get the IP address, and then goes
and says 'what should I do' and then because bootproto isnt correct tries for a
dynamic ip again. 

Bug level: nitpick.
Comment 1 Stephen John Smoogen 2003-10-28 15:24:26 EST
Ok a bit more than a nitpick. The problem turns out to be that the code isnt
circling but that it is asking for the same information as before for two
different reasons.

First time is because it cant find a DHCP server on startup and then asks for
the info so that it can get the ks.cfg from the ftp server. Fill in those values
and it gets the values. Then the second DHCP request is because it has loaded
the ks.cfg correctly and is looking for the info again (putting in a 

network --bootproto=static

did not help this slowdown. 
Comment 2 Stephen John Smoogen 2003-11-06 13:35:37 EST
I found some items that werent documented in the manuals but was in
the source code and /usr/share/documentation for anaconda.

By using the flags ip= ksdevice= gateway= etc.. I can get anaconda to
do the right thing without doing extra DHCP lookups.

Note You need to log in before you can comment on or make changes to this bug.