Bug 1082638 - VDSM failed to start correctly due to sudo hanging.
Summary: VDSM failed to start correctly due to sudo hanging.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.3.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Oved Ourfali
QA Contact: Jiri Belka
URL:
Whiteboard:
Depends On: 1081282 1092400
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-31 14:28 UTC by Gordon Watson
Modified: 2019-04-28 09:56 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 19:21:20 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0362 normal SHIPPED_LIVE vdsm 3.6.0 bug fix and enhancement update 2016-03-09 23:49:32 UTC
oVirt gerrit 42219 master MERGED spec: require kernel version to avoid sudo hanging Never

Description Gordon Watson 2014-03-31 14:28:06 UTC
Description of problem:

The intent of this bug is just to point out a problem that happened recently and that it is currently being addressed via a kernel bug, BZ 1081282. 

The problem is that the 'sudo' command hung in getifaddrs(). 

For the customer that encountered this, when they started VDSM, the supervdsm process failed to start due to 'sudo' hanging and VDSM was therefore unable to connect to supervdsm's socket. The host then became Non-Responsive.


Version-Release number of selected component (if applicable):

RHEV 3.1
RHEL 6.5 hosts with 'vdsm-4.13.2-0.11'


How reproducible:

It only happened the one time.


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 12 Max Kovgan 2015-06-28 14:12:21 UTC
ovirt-3.6.0-3 release

Comment 13 Jiri Belka 2015-07-31 14:44:48 UTC
BZ1081282 is related to RHEL6. ovirt/rhevm 3.6.x won't support RHEL6 as hosts.

vdsm requires kernel >= 3.10.0-132.el7, although BZ1081282 doesn't mention anything about RHEL7 kernel...

Please put valid keyword so it's clear it doesn't require any QA action. Thank you.


# yum deplist vdsm | grep 'dependency.*kernel'
  dependency: kernel >= 3.10.0-132.el7
# yum info vdsm | egrep "^Release|^Version"
Version     : 4.17.0
Release     : 1054.git562e711.el7

Comment 14 Yeela Kaplan 2015-08-02 07:37:23 UTC
Jiri,
Please notice this bug is also dependant on BZ#1092400 which is rhel7.
so I think there's no need  in adding a flag.

Comment 15 Jiri Belka 2015-08-05 09:52:43 UTC
ok, vdsm-4.17.0-1198.git6ede99a.el7.noarch / 3.6.0-4 (no issue found)

# rpm -qRp http://bob.eng.lab.tlv.redhat.com/builds/3.6/3.6.0/3.6.0-4/snapshot/rpm/el7Server/noarch/vdsm-4.17.0-1198.git6ede99a.el7.noarch.rpm | grep ^kernel
kernel >= 3.10.0-132.el7
# rpm -q kernel
kernel-3.10.0-229.7.2.el7.x86_64

Comment 18 errata-xmlrpc 2016-03-09 19:21:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0362.html


Note You need to log in before you can comment on or make changes to this bug.