Bug 1082675 - targetcli set attribute emulate_write_cache=1 is ignored
Summary: targetcli set attribute emulate_write_cache=1 is ignored
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Maurizio Lombardi
QA Contact: Bruno Goncalves
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-31 15:24 UTC by Eric Murphy
Modified: 2018-07-27 11:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-27 11:26:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Eric Murphy 2014-03-31 15:24:23 UTC
Description of problem:
targetcli set attribute emulate_write_cache=1 is ignored


Version-Release number of selected component (if applicable):
Backstore plugin block v4.1.0-rc2-ml



How reproducible:
Always


Steps to Reproduce:
1. Create a block storage device in targetcli
2. Enter the block device and issue the command "set attribute emulate_write_cache=1"


Actual results:
Parameter emulate_write_cache is now '0'.


Expected results:
Parameter emulate_write_cache is now '1' 
Or an error message stating the reason why the change failed

Additional info:
/> cd backstores/block/TestSan01_block
/backstores/b...stSan01_block> ls
o- TestSan01_block ................................................................ [/dev/sda (136.7GiB) write-thru activated]
/backstores/b...stSan01_block> set attribute emulate_write_cache=1
Parameter emulate_write_cache is now '0'.

Comment 2 Eric Murphy 2014-03-31 17:00:16 UTC
The change being ignored is not a bug, I found more information in journalctl.  There should still be more information about why the change was ignored from within the targetcli program.

From journalctl:

Mar 31 10:19:18 testsan01.localhost.local kernel: emulate_write_cache cannot be changed when underlying HW reports WriteCacheEnabled, ignoring request

Comment 3 Andy Grover 2014-03-31 20:19:32 UTC
The kernel code is returning a success error value but printing that message, so there's no way for targetcli to know anything went wrong. We probably want to change the kernel to return an error code (EINVAL) in this case.

Comment 7 Maurizio Lombardi 2018-07-27 11:26:26 UTC
I think this is an intended behaviour.

copy pasting from the rtslib library commit b0c41a578bb43db1e787106c2dbc2b46465476a5

    Do not set emulate_write_cache based on write_back param for block
    
    Since the kernel's d0c8b259f (in 3.9+), setting emulate_write_cache for
    block backstores has not done anything -- the kernel now actually uses
    the queue's REQ_FLUSH flag.
    
    No longer set this attribute, but keep the parameter for backwards
    compatibility.

I will close this bug.


Note You need to log in before you can comment on or make changes to this bug.