Bug 10828 - segmentation fault (11) when reading client certificates
Summary: segmentation fault (11) when reading client certificates
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Secure Web Server
Classification: Retired
Component: secureweb (Show other bugs)
(Show other bugs)
Version: 3.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-14 19:49 UTC by s.j.c.jonker
Modified: 2014-08-12 12:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-12 12:03:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description s.j.c.jonker 2000-04-14 19:49:33 UTC
This is actually for secureweb 3.2. I protect a directory with
(httpd.conf):
<Directory /home/httpd/html/foo>
  SSLRequireSSL
  SSLVerifyClient require
  SSLVerifyDepth 10
</Directory>

When I try to access that directory from a client computer (with a client
certificate) I get the error "A connection with the server cannot be
established" (IE) or "Document contains no data" (Netscape) and the only
log on the server is in error_log which says "[Fri Apr 14 16:01:10 2000]
[notice] child pid 16161 exit signal Segmentation fault (11)".  Is this
the same bug that was fixed in the secureweb update for 3.1?

Comment 1 andyl 2000-04-17 15:14:59 UTC
I have the same problem, with an almost identical config.  Additionally, the seg
fault problem doesn't occur upon initial startup of the apache process; I've
noticed this problem only after a couple of days have gone by (as a result,
stopping and starting the server will fix it temporarily).

Comment 2 Anonymous 2000-04-17 16:16:59 UTC
Some more comments...  The reading and verifying of client certificates used to
work with RedHat 6.1 Profess.  After I upgraded to 6.2 I cannot read client
certificates at all.  If I set the log level to debug I can see that the ssl
engine is requesting and reading the client certificate properly, however once
it is done the httpsd process simply dies...  I don't know if it is because of
the switch from openssl to bsafe-ssl, but can anyone out there using RedHat 6.2
Professional read client certificates?


Note You need to log in before you can comment on or make changes to this bug.