Bug 1082858 (CVE-2014-0157) - CVE-2014-0157 openstack-horizon: XSS in Horizon orchestration dashboard when using a malicious template
Summary: CVE-2014-0157 openstack-horizon: XSS in Horizon orchestration dashboard when ...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2014-0157
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20140408,reported=2...
Depends On: 1085825 1085826 1086019 1086023
Blocks: 1082859
TreeView+ depends on / blocked
 
Reported: 2014-04-01 01:29 UTC by Murray McAllister
Modified: 2019-06-08 19:58 UTC (History)
23 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-06 05:52:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2014:0581 normal SHIPPED_LIVE Low: python-django-horizon security update 2014-05-30 00:26:35 UTC

Description Murray McAllister 2014-04-01 01:29:25 UTC
It was reported that, if an Horizon user were tricked into using a malicious template in the Orchestration/Stack section of Horizon, it would be possible for an attacker to conduct cross-site scripting (XSS) attacks.

The original report notes "2013.2.1 version up to 2013.2.2" are affected.

Acknowledgements:

Red Hat would like to thank the OpenStack project for reporting this issue. Upstream acknowledges Cristian Fiorentino from Intel as the original reporter.

Comment 4 Murray McAllister 2014-04-09 07:34:09 UTC
This issue is public now:

http://seclists.org/oss-sec/2014/q2/35

Comment 5 Murray McAllister 2014-04-09 13:02:24 UTC
Created python-django-horizon tracking bugs for this issue:

Affects: fedora-all [bug 1085825]
Affects: epel-6 [bug 1085826]

Comment 8 Fedora Update System 2014-04-23 04:34:10 UTC
python-django-horizon-2013.2.3-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 errata-xmlrpc 2014-05-29 20:33:23 UTC
This issue has been addressed in following products:

  OpenStack 4 for RHEL 6

Via RHSA-2014:0581 https://rhn.redhat.com/errata/RHSA-2014-0581.html


Note You need to log in before you can comment on or make changes to this bug.