Bug 10830 - RPM -e is not freeing disk space in a RAID0
Summary: RPM -e is not freeing disk space in a RAID0
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-15 00:56 UTC by sheflug
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-14 14:25:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sheflug 2000-04-15 00:56:01 UTC
It looks like 'rpm -e' is not freeing space when packeges are deleted. I
have a root filesystem mounted in a RAID0 (/dev/md0) and when a package is
deleted with 'rpm -e' the corresponding disk space is not freed according
to 'df'. Everything else seems to work. When erasing files with 'rm', df
correctly displays the bigger available space. Does someone know if
either "rpm" or "md0 driver" or "df" has a bug ? Any help would be very
much appreciated.

Ximenes Resende
http://cv-2-8.campusview.indiana.edu/~ximenes/

Comment 1 Bill Nottingham 2000-04-17 15:08:59 UTC
If they are libraries that are in use, the disk space won't
be freed until the last program that uses those libraries
has finished.

Or are you seeing something else?

Comment 2 Jeff Johnson 2000-05-11 16:49:59 UTC
Without knowing what packages are/were involved, it's gonna be hard to
analyze whether libraries were involved or not. What packages? Do the
packages have libraries?

Comment 3 Jeff Johnson 2000-05-14 14:25:59 UTC
Closed for lack of input. Please feel free to reopen.


Note You need to log in before you can comment on or make changes to this bug.