Bug 1083054 - java.nio.BufferOverflowException at jbossweb-7.4.0.Beta4.jar:7.4.0.Beta4
Summary: java.nio.BufferOverflowException at jbossweb-7.4.0.Beta4.jar:7.4.0.Beta4
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER2
: EAP 6.3.0
Assignee: Rémy Maucherat
QA Contact: Radim Hatlapatka
Russell Dickenson
URL:
Whiteboard:
: 1081958 (view as bug list)
Depends On: 1083568
Blocks: 1082560
TreeView+ depends on / blocked
 
Reported: 2014-04-01 11:58 UTC by Lucas Ponce
Modified: 2014-06-28 15:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-28 15:27:44 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat One Jira Issue Tracker GTNPORTAL-3435 Major Resolved Import .zip REST API broken with EAP 6.3.0.Alpha1 2017-01-05 11:46:07 UTC

Internal Links: 1083568

Description Lucas Ponce 2014-04-01 11:58:41 UTC
Description of problem:

JBoss Portal 6.2 will be based on JBoss EAP 6.3.0.

In the import .zip operation via REST this bug can be reproduced.

Version-Release number of selected component (if applicable):

JBoss EAP Alpha1, and DR6.

More info:
https://issues.jboss.org/browse/GTNPORTAL-3435

How reproducible:

Always.

Steps to Reproduce:

Start a REST import operation using curl command described in case:
https://issues.jboss.org/browse/GTNPORTAL-3435

Actual results:

java.nio.BufferOverflowException at jbossweb-7.4.0.Beta4.jar:7.4.0.Beta4

produced in jbossweb.jar component.

Expected results:

No exception.

Additional info:

There is a workaround:
- Change from NIO2 to JIO in http connector.

There is a patch:
- jbossweb-7.4.1.Final.jar

Expectations would be to add 7.4.1.Final.jar component into EAP 6.3.0 release.

Comment 2 Radim Hatlapatka 2014-04-30 11:29:43 UTC
*** Bug 1081958 has been marked as a duplicate of this bug. ***

Comment 3 Radim Hatlapatka 2014-04-30 11:30:26 UTC
Verified with EAP 6.3.0.ER2

Comment 4 JBoss JIRA Server 2014-06-13 12:25:10 UTC
Lucas Ponce <ponce.ballesteros@gmail.com> updated the status of jira GTNPORTAL-3435 to Resolved


Note You need to log in before you can comment on or make changes to this bug.