Bug 1083166 - Make hammer repository update match what can be done via the UI
Summary: Make hammer repository update match what can be done via the UI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hammer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-01 15:10 UTC by Og Maciel
Modified: 2019-09-26 17:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-02 14:14:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 4984 0 None None None 2016-04-22 16:26:21 UTC

Description Og Maciel 2014-04-01 15:10:18 UTC
Description of problem:

The web ui (see screenshot) allows you to edit the following fields for an existing repository:

* URL
* Publish via HTTP
* GPG Key

However, hammer cli only allows the following:

# hammer repository update --helpUsage:
    hammer repository update [OPTIONS]

Options:
    --gpg-key-id GPG_KEY_ID       id of a gpg key that will be assigned to this repository
    --id ID                       resource id
    --publish-via-http ENABLE     Publish Via HTTP
                                  One of true/false, yes/no, 1/0.

As you can see we're missing the ability to change the URL

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.7-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.7-1.el6_5.noarch
* candlepin-tomcat6-0.9.7-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.5.0.13-1.el6sat.git.0.8bc20ed.noarch
* foreman-compute-1.5.0.13-1.el6sat.git.0.8bc20ed.noarch
* foreman-libvirt-1.5.0.13-1.el6sat.git.0.8bc20ed.noarch
* foreman-postgresql-1.5.0.13-1.el6sat.git.0.8bc20ed.noarch
* foreman-proxy-1.5.4-1.el6sat.noarch
* foreman-selinux-1.5.0-0.develop.el6sat.noarch
* katello-1.5.0-19.el6sat.noarch
* katello-apache-1.0-1.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.31-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.1-0.4.beta.el6sat.noarch
* pulp-nodes-parent-2.3.1-0.4.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.1-0.4.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.1-0.4.beta.el6sat.noarch
* pulp-selinux-2.3.1-0.4.beta.el6sat.noarch
* pulp-server-2.3.1-0.4.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.8-1.el6sat.noarch
* rubygem-hammer_cli-0.1.0-4.el6sat.noarch
* rubygem-hammer_cli_foreman-0.1.0-5.el6sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.2-2.el6sat.noarch
* rubygem-hammer_cli_katello-0.0.3-11.el6sat.noarch

How reproducible:


Steps to Reproduce:
1. Create a new repository via the CLI
2. Try to update its URL
3.

Actual results:

The URL is not an option for the update command


Expected results:


Additional info:

Comment 2 Bryan Kearney 2014-04-02 14:07:12 UTC
Connecting redmine issue http://projects.theforeman.org/issues/4984 from this bug

Comment 3 Bryan Kearney 2014-04-08 12:27:33 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/4984 has been closed

Comment 5 Sachin Ghai 2014-05-07 10:30:32 UTC
Verified with Satellite-6.0.3-RHEL-6-20140430.4


[root@qetello02 ~]# hammer repository update --help
Usage:
    hammer repository update [OPTIONS]

Options:
    --gpg-key-id GPG_KEY_ID       ID of a gpg key that will be assigned to this repository
    --id ID                       resource id
    --publish-via-http ENABLE     Publish Via HTTP
                                  One of true/false, yes/no, 1/0.
    --url URL                     the feed url of the original repository
    -h, --help                    print help


update command includes --url option.

Comment 6 Bryan Kearney 2014-07-02 14:09:54 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Comment 7 Bryan Kearney 2014-07-02 14:10:11 UTC
This was delivered in 6.0.3, the Beta version of Satellite 6.0

Comment 8 Bryan Kearney 2014-07-02 14:14:46 UTC
This was delivered in the Satellite 6 Beta (6.0.3)


Note You need to log in before you can comment on or make changes to this bug.