Bug 10832 - recent changes to init.d/network break network startup
Summary: recent changes to init.d/network break network startup
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-15 10:06 UTC by Gary Peck
Modified: 2014-03-17 02:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-17 14:50:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gary Peck 2000-04-15 10:06:14 UTC
Since upgrading to initscripts-5.07-1, my eth0 card was not being turned on
during bootup or during a manual "/etc/rc.d/init.d/network restart".

I traced the problem down to the following part of init.d/network:
---
for i in $interfaces; do
        if egrep -L "ONBOOT=\"?[Nn][Oo]\"?" ifcfg-$i | grep -v "^#"
>/dev/null ; then
                # Probe module to preserve interface ordering
                /sbin/ifconfig $i >/dev/null 2>&1
        else
                action "Bringing up interface $i" ./ifup $i boot
        fi
done
---
the "egrep -L" was doing the opposite of what was intended, and should be
changed to "egrep -l".

Comment 1 Bill Nottingham 2000-04-17 14:50:59 UTC
Actually, just changing it to 'egrep -L "^<pattern>"
should do what's desired.

Fixed in 5.08-1 and later; thanks for the bug report.


Note You need to log in before you can comment on or make changes to this bug.