Bug 1083432 - group is marked as installed, even if install of the packages failed
group is marked as installed, even if install of the packages failed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
: 1082290 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-02 05:03 EDT by Tim Lauridsen
Modified: 2014-09-30 19:42 EDT (History)
6 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.0.8-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-31 19:59:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Lauridsen 2014-04-02 05:03:13 EDT
Description of problem:
When installing a group and there is a issue in package download, so the packages 
can't be downloaded and install, the group is still marked as installed.

when using the dnf.Base.group_install public api will mark the group as installed, even if the transaction is not completed.


Version-Release number of selected component (if applicable):
0.4.19

How reproducible:


Steps to Reproduce:
1. dnf group remove firefox
2. dnf group install firefox
3. <disable the network connect, before the packages is download>

# cat /var/lib/dnf/groups.json 
{"firefox": ["icedtea-web", "firefox"]}

Actual results:
group is marked as installed

Expected results:
group is not marked as installed, before the mandatory packages is installed

Additional info:
Comment 1 Radek Holy 2014-04-02 07:10:39 EDT
Hello, thank you for the report. We will take a look.
Comment 2 Ales Kozumplik 2014-04-17 04:53:00 EDT
Fixed by series of patches on the master branch between 0b40b6a and eab2f56.
Comment 3 Ales Kozumplik 2014-04-22 15:43:35 EDT
*** Bug 1082290 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2014-05-02 04:32:49 EDT
dnf-0.5.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.5.1-1.fc20
Comment 5 Fedora Update System 2014-05-02 17:05:21 EDT
Package dnf-0.5.1-1.fc20, hawkey-0.4.14-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.5.1-1.fc20 hawkey-0.4.14-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-5937/hawkey-0.4.14-1.fc20,dnf-0.5.1-1.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-05-28 08:10:41 EDT
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20
Comment 7 Fedora Update System 2014-05-28 19:50:38 EDT
Package dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.0.8-2.fc20 libsolv-0.6.1-1.git6d968f1.fc20 hawkey-0.4.16-1.fc20 dnf-0.5.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6789/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-05-31 19:59:17 EDT
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Michael Monreal 2014-06-02 17:13:38 EDT
I filed bug 1082290 (duped of this). Tested the new version and I still cannot install a group, rollback and install it again. Test this:

$ sudo dnf group install development-tools
$ sudo dnf history rollback <transaction before group install>

Followed by:

$ sudo dnf group install -v development-tools
Config time: 0.006
cachedir: /var/cache/dnf/x86_64/20
Failed loading plugin: copr
Loaded plugins: generate_completion_cache, download, builddep, kickstart, noroot, debuginfo-install
initialized BuildDep plugin
initialized Noroot plugin
initialized DebuginfoInstall plugin
dnf version: 0.5.2
repo: using cache for: rhughes-f20-gnome-3-12
not found deltainfo for: Copr repo for f20-gnome-3-12 owned by rhughes
repo: using cache for: fedora
not found deltainfo for: Fedora 20 - x86_64
repo: using cache for: rpmfusion-free-updates
not found deltainfo for: RPM Fusion for Fedora 20 - Free - Updates
repo: using cache for: adobe-linux-x86_64
not found deltainfo for: Adobe Systems Incorporated
repo: using cache for: rpmfusion-nonfree-updates
not found deltainfo for: RPM Fusion for Fedora 20 - Nonfree - Updates
repo: using cache for: rpmfusion-free
not found deltainfo for: RPM Fusion for Fedora 20 - Free
repo: using cache for: updates
repo: using cache for: rpmfusion-nonfree
not found deltainfo for: RPM Fusion for Fedora 20 - Nonfree
hawkey sack setup time: 0.229
group persistor md version: 0.5.0
group time: 0.251
Error: No relevant match for the specified 'development-tools'.
Cleaning up.

Only way I can install the group is after "sudo dnf group mark remove development-tools"

Note You need to log in before you can comment on or make changes to this bug.