Bug 1083461 - Could not generate random mac address when creating new vm
Summary: Could not generate random mac address when creating new vm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-02 09:55 UTC by zhengqin
Modified: 2015-03-05 10:03 UTC (History)
6 users (show)

Fixed In Version: virt-manager-1.1.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 10:03:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0427 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2015-03-05 14:38:46 UTC

Description zhengqin 2014-04-02 09:55:24 UTC
Description of problem:

On New VM step 5 of 5 "Ready to begin installation" window: 
1. If uncheck "Set a fixed MAC address" checkbox, the New VM's mac address is still same with fixed Mac Address. 
2. If clear fixed MAC address and then uncheck "Set a fixed MAC address" checkbox, an error about mac address format will pop up.

That's to day, the checkbox "Set a fixed MAC address" does not work, create vm window will be always use the fixed mac address whether this checkbox checked or not.


Version-Release number of selected component:
virt-manager-0.10.0-20.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Start virt-manager.

2. Create a New VM by PXE or other method until step 5 of 5 "Ready to begin installation" window.

3. Clear fixed MAC address and then uncheck "Set a fixed MAC address" checkbox.


Actual result:
1. An error about mac address format will pop up.
2. If uncheck "Set a fixed MAC address" checkbox at step 3, the New VM's mac address is still same with fixed Mac Address. 
3. That's to day, the checkbox "Set a fixed MAC address" does not work, create vm window will be always use the fixed mac address whether this checkbox checked or not.




Expected results:
1. No error will pop up and a random mac address will be generated without "Set a fixed MAC address" checked.
2. The New VM's mac address should be random instead of fixed one.



Additional info:
1. This issue also occurs on RHEL6.

Comment 1 Giuseppe Scrivano 2014-07-22 08:42:53 UTC
fixed upstream by:

commit 312b349fceffec38dd04aa35d053b082fe698f3a
Author: Giuseppe Scrivano <gscrivan>
Date:   Mon Jul 21 11:28:28 2014 +0200

    virt-manager, create: honor untoggled "Set a fixed MAC address"
    
    Closes: https://bugzilla.redhat.com/show_bug.cgi?id=1083461
    
    Signed-off-by: Giuseppe Scrivano <gscrivan>

Comment 3 Cui Lei 2014-09-29 09:24:16 UTC
I can reproduce this issue with virt-manager-0.10.0-20.el7.noarch.

Verify the issue with virt-manager-1.1.0-3.el7,

This issue was fixed. So change the status from 'ON_QA' to 'VERIFIED'

Comment 6 errata-xmlrpc 2015-03-05 10:03:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0427.html


Note You need to log in before you can comment on or make changes to this bug.