Bug 10836 - port-allow and pasv-allow syntax wrong in ftpaccess man page
Summary: port-allow and pasv-allow syntax wrong in ftpaccess man page
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-15 17:21 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-15 17:21:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-04-15 17:21:08 UTC
The syntax for pasv-allow and port-allow seems to be wrong in ftpaccess(5)
man page.

It says:

port-allow <class> [<addrglob> ...]
pasv-allow <class> [<addrglob> ...]

This should be:

port-allow <class> [<cidr> ...]
pasv-allow <class> [<cidr> ...]

To duplicate, if you put something like:

port-allow all *
pasv-allow all *

in /etc/ftpaccess, ftpd will die with SIG11.

On the other hand this works:

port-allow all 0.0.0.0/0
pasv-allow all 0.0.0.0/0

Comment 1 Henri Schlereth 2000-07-12 23:50:10 UTC
man page still contains same info.

added to ftpaccess
port-allow all *
pasv-allow all *

Didnt get a sig-11. Fixed in Rawhide wu-ftpd-2.6.1-1


Note You need to log in before you can comment on or make changes to this bug.