Bug 1083877 - CLI GUI offers write and undefine operations on read-only attribute
Summary: CLI GUI offers write and undefine operations on read-only attribute
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Stan Silvert
QA Contact: Petr Kremensky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-03 07:11 UTC by Rostislav Svoboda
Modified: 2017-10-10 00:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-04 11:47:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Rostislav Svoboda 2014-04-03 07:11:28 UTC
This issue came up during verification of https://bugzilla.redhat.com/show_bug.cgi?id=987898#c11

CLI GUI offers write and undefine operations on read-only attribute
Details from https://bugzilla.redhat.com/show_bug.cgi?id=987898#c13 provided by Rebecca Searls:

> I consulted with Brian Stansberry and Stan Silvert on this change.
> Brian speculated this might be a general problem that occurs with any
> read-only attribute.  Stan confirmed it.  
> 
> -- Stan wrote ...
> > I implemented the fix but I don't like the way it turned out from a
> > usability standpoint.
> > 
> > If it is a read-only attribute then there will be no operations menu
> > when you right-click the node.  That's very confusing because some nodes
> > will have a menu and others will not.
> > 
> > The alternative to displaying nothing is to display some sort of error
> > or warning like "This attribute is read only".  IMO, that's more
> > annoying than just letting the user execute the command.
> > 
> > Furthermore, the regular CLI does not do this check either.  It happily
> > performs tab completion and lets you execute.
> 
> > So I think it's best if we just leave it alone and tell the customer it
> > is working as designed.

Comment 1 Stan Silvert 2014-04-04 11:47:26 UTC
Working as designed.  IMO, the proposed change would harm usability.


Note You need to log in before you can comment on or make changes to this bug.