Bug 1083938 - [RFE] Support fence_kdump configuration for generic clusters
Summary: [RFE] Support fence_kdump configuration for generic clusters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 6.6
Assignee: kdump team
QA Contact: Qiao Zhao
URL:
Whiteboard:
Depends On:
Blocks: 1079821 1086988
TreeView+ depends on / blocked
 
Reported: 2014-04-03 09:27 UTC by Martin Perina
Modified: 2014-10-14 07:09 UTC (History)
13 users (show)

Fixed In Version: kexec-tools-2.0.0-274.el6
Doc Type: Enhancement
Doc Text:
Feature: Reason: Result (if any):
Clone Of:
: 1086988 (view as bug list)
Environment:
Last Closed: 2014-10-14 07:09:09 UTC
Target Upstream Version:


Attachments (Terms of Use)
[RHEL6.6 PATCH 1/4] Add function is_pcs_fence_kdump (1.48 KB, patch)
2014-04-15 12:46 UTC, Martin Perina
no flags Details | Diff
[RHEL6.6 PATCH 2/4] Add function get_pcs_cluster_nodes (1.55 KB, patch)
2014-04-15 12:47 UTC, Martin Perina
no flags Details | Diff
[RHEL6.6 PATCH 3/4] Code cleanup in fence_kdump setup section (1.57 KB, patch)
2014-04-15 12:47 UTC, Martin Perina
no flags Details | Diff
[RHEL6.6 PATCH 4/4] Add fence_kdump support for generic clusters (5.06 KB, patch)
2014-04-15 12:47 UTC, Martin Perina
no flags Details | Diff
[RHEL6.6 PATCH 1/4 v2] Add function is_pcs_fence_kdump (1.49 KB, patch)
2014-04-16 07:34 UTC, Martin Perina
no flags Details | Diff
[RHEL6.6 PATCH 2/4 v2] Add function get_pcs_cluster_nodes (1.56 KB, patch)
2014-04-16 07:35 UTC, Martin Perina
no flags Details | Diff
[RHEL6.6 PATCH 3/4 v2] Add function setup_cluster_nodes_and_options (3.67 KB, patch)
2014-04-16 07:35 UTC, Martin Perina
no flags Details | Diff
[RHEL6.6 PATCH 4/4 v2] Add fence_kdump support for generic clusters (5.27 KB, patch)
2014-04-16 07:36 UTC, Martin Perina
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1502 normal SHIPPED_LIVE kexec-tools bug fix and enhancement update 2014-10-14 01:28:09 UTC

Description Martin Perina 2014-04-03 09:27:16 UTC
kexec-tools-2.0.0-273 contains automatic configuration of fence_kdump from Pacemaker configuration. Unfortunately, this support is tightly bound to Pacemaker and cannot be used for other clusters like oVirt/RHEVM.

Proposed solution, which has already been merged to Fedora kexec-tools:

  - Add two new options to kdump.conf

      fence_kdump_nodes
          - List of hosts separated by space to send fence_kdump
            notification to (this option is mandatory to enable
            fence_kdump)

      fence_kdump_args
          - Command line arguments for fence_kdump_send (it can
            contain all valid arguments except hosts to send
            notification to)


  - Modify kdump behavior due to new options

      1) If fence_kdump_nodes option is set and fence_kdump_send
         is found and executable -> configure network for kdump
         and execute fence_kdump_send with those nodes (and also
         with args specified in fence_kdump_args if not empty)

      2) If fence_kdump_nodes is not set, try to configure fence_kdump
         using cluster settings (current behavior). This should stay
         in kexec-tools not to break compatibility and can be removed
         after Pacemaker will start using new options.

Comment 1 Dave Young 2014-04-11 07:30:58 UTC
Hi, Martin

Do you have a RHEL7 bug for this? We need to make it in RHEL7 before RHEL6...
But it's too late for RHEL7.0 thus it should target for 7.1..

Thanks
Dave

Comment 2 Martin Perina 2014-04-12 11:14:54 UTC
I cloned this bug for RHEL 7 as BZ1086988

Comment 3 Martin Perina 2014-04-15 12:46:38 UTC
Created attachment 886467 [details]
[RHEL6.6 PATCH 1/4] Add function is_pcs_fence_kdump

Comment 4 Martin Perina 2014-04-15 12:47:08 UTC
Created attachment 886469 [details]
[RHEL6.6 PATCH 2/4] Add function get_pcs_cluster_nodes

Comment 5 Martin Perina 2014-04-15 12:47:33 UTC
Created attachment 886470 [details]
[RHEL6.6 PATCH 3/4] Code cleanup in fence_kdump setup section

Comment 6 Martin Perina 2014-04-15 12:47:55 UTC
Created attachment 886471 [details]
[RHEL6.6 PATCH 4/4] Add fence_kdump support for generic clusters

Comment 7 Martin Perina 2014-04-16 07:34:42 UTC
Created attachment 886772 [details]
[RHEL6.6 PATCH 1/4 v2] Add function is_pcs_fence_kdump

Comment 8 Martin Perina 2014-04-16 07:35:13 UTC
Created attachment 886773 [details]
[RHEL6.6 PATCH 2/4 v2] Add function get_pcs_cluster_nodes

Comment 9 Martin Perina 2014-04-16 07:35:36 UTC
Created attachment 886774 [details]
[RHEL6.6 PATCH 3/4 v2] Add function setup_cluster_nodes_and_options

Comment 10 Martin Perina 2014-04-16 07:36:00 UTC
Created attachment 886776 [details]
[RHEL6.6 PATCH 4/4 v2] Add fence_kdump support for generic clusters

Comment 11 Martin Perina 2014-05-15 07:29:21 UTC
This feature is independent of any particular cluster software, everyone can use it as is. So I suggest this testing scenarios:

1) Test if no regressions were introduced with this patch to Pacemaker
     - Pacemaker uses its own method to configure fence_kdump support, it doesn't
       use new options fence_kdump_nodes and fence_kdump_args

2) Test if new options fence_kdump_nodes and fence_kdump_args works
     - only fence-agents-kdump RPM is needed to test this feature
     - I suggest this minimal scenario:
         - let's have host1 (it will contain fence_kdump configuration) 
           and host2 (it will listen for fence_kdump messages)
         - On host1 add following option to kdump.conf (assuming that host2 is 
           resolvable, otherwise IP of host2 has to be entered):
               fence_kdump_nodes host2
           And restart kdump service
         - On host2 configure firewall to enable UDP connections to port 7410
         - On host2 execute following command:
               /usr/sbin/fence_kdump -t 3600 -v 127.0.0.1
           This will display all incoming fence_kdump messages (with above 
           configuration every 10 seconds message should be received while host1
           is kdumping)
         - Execute kernel crash on host1 using sysrq trigger
              echo c > /proc/sysrq-trigger

Comment 17 errata-xmlrpc 2014-10-14 07:09:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1502.html


Note You need to log in before you can comment on or make changes to this bug.