Bug 1084055 - Storage node has internal server metrics "Anti Entropy Sessions" marked as unavailable
Summary: Storage node has internal server metrics "Anti Entropy Sessions" marked as un...
Keywords:
Status: CLOSED DUPLICATE of bug 1084056
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Storage Node
Version: JON 3.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ER04
: JON 3.3.0
Assignee: Stefan Negrea
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-03 14:03 UTC by bkramer
Modified: 2018-12-04 17:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-22 17:20:29 UTC
Type: Bug


Attachments (Terms of Use)

Description bkramer 2014-04-03 14:03:08 UTC
Description of problem:
First time, when JBoss ON is installed and started, *Anti Entropy Sessions* resource will not be discovered and will not be listed under Storage Node's Internal Server Metrics subfolder. However, execution of *Repair* operation will generate *Anti Entropy Sessions" which will be discovered after JBoss ON Agent's full discovery. The status of this metric will be UP.

If we stop the storage node and start it again, previously discovered *Anti Entropy Session* will not exist any more and because of that it will be marked as DOWN in JBoss ON UI, until next "Repair" operation...

Version-Release number of selected component (if applicable):
JBoss ON 3.2

How reproducible:
Always

Steps to Reproduce:
1. Install JBoss ON 3.2;
2. In JBoss ON UI navigate to Inventory -> Servers -> RHQ Storage Node -> Internal Server Metrics and confirm that *Anti Entropy Sessions* are not listed;
3. For this storage node, execute "Repair" operation;
4. Execute "discovery -f" on the JBoss ON Agent command line;
5. Execute "avail --force" on the JBoss ON Agent command line;
6. Navigate as before to Internal Server Metrics for this storage node and confirm that *Anti Entropy Sessions* are discovered and UP;
7. Stop storage node: ./rhqctl stop --storage;
8. Start storage node: ./rhqctl start --storage;
9. Navigate to the Internal Server Metrics for this storage node and confirm that *Anti Entropy Sessions* resource is down.

Actual results:
Anti Entropy Sessions resource is discovered and monitored.

Expected results:
We should not monitor Anti Entropy Sessions resource as it will go down after every storage node restart.

Additional info:

Comment 1 Stefan Negrea 2014-09-22 17:20:29 UTC

*** This bug has been marked as a duplicate of bug 1084056 ***


Note You need to log in before you can comment on or make changes to this bug.