Bug 1084104 - Blank screen while connecting to Xorg based vnc on rhel6
Summary: Blank screen while connecting to Xorg based vnc on rhel6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-ati
Version: 6.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jérôme Glisse
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1075802 1159931
TreeView+ depends on / blocked
 
Reported: 2014-04-03 15:27 UTC by Ashish Shah
Modified: 2019-08-15 03:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the radeon driver did not work correctly with the Virtual Network Computing (VNC) module if hardware acceleration was enabled. Consequently, a VNC client connected to a computer set up this way only displayed a blank screen. With this update, this problem has been resolved, and it is now possible to use VNC with the aforementioned setup.
Clone Of:
Environment:
Last Closed: 2015-07-22 06:25:14 UTC
Target Upstream Version:


Attachments (Terms of Use)
Xorg log (28.34 KB, text/plain)
2015-02-16 13:37 UTC, Milan Barta
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1301 normal SHIPPED_LIVE libdrm, mesa, xorg-x11-drv-ati, and xorg-x11-drv-intel update 2015-07-20 17:53:54 UTC

Description Ashish Shah 2014-04-03 15:27:00 UTC
Hello,

A customer have reported issue with Xorg based vnc showing blank screen.
I am able to reproduce the problem locally.
I see blank screen while connecting to Xorg based vnc configured on rhel6 using tigervnc server module.. Problem looks specific to radeon and that too one particular ES1000 hardware... e.g. In my testing I observed Radeon ES1000 VGA with Subsystem: 103c:31fb has problem but no problem with ES1000 VGA having Subsystem: 1028:01b3

Problem hardware:

01:03.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] ES1000 (rev 02)

01:03.0 0300: 1002:515e (rev 02) (prog-if 00 [VGA controller])
        Subsystem: 103c:31fb

Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR+ FastB2B- DisINTx- Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

        Latency: 64 (2000ns min), Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Region 1: I/O ports at 2000 [size=256]
        Region 2: Memory at fd7f0000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at fd700000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 2

Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)

                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Kernel driver in use: radeon
        Kernel modules: radeon, radeonfb

No Problem hardware:

10:0d.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] ES1000 (rev 02)

10:0d.0 0300: 1002:515e (rev 02) (prog-if 00 [VGA controller])
        Subsystem: 1028:01b3

Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop+ ParErr- Stepping+ SERR+ FastB2B- DisINTx- Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

        Latency: 32 (2000ns min), Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 19
        Region 0: Memory at d0000000 (32-bit, prefetchable) [size=128M]
        Region 1: I/O ports at dc00 [size=256]
        Region 2: Memory at fc2d0000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at fc100000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 2

Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)

                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Kernel driver in use: radeon
        Kernel modules: radeon, radeonfb

I see display on vncviewer screen after around 6 to 7 minutes. Then if I click on a listed user for login, password prompt is also displayed after delay of few minutes. 

Problem can be workaround by disabling acceleration using --> Option "NoAccel" "true" <-- in xorg.conf 
Drawing screen contents over vnc takes huge delay when acceleration is enabled?

Customer would like the driver to work out of the box without needing to disable acceleration in configuration file.

Regards,
Ashish

Comment 11 Milan Barta 2015-02-16 13:37:19 UTC
Created attachment 992192 [details]
Xorg log

Hi,

I was able to reproduce the "blank screen" issue when connecting to a VNC server using an Xorg module.

The component versions I was able to reproduce on were:
xorg-x11-drv-ati-7.3.99-2.el6.x86_64
xorg-x11-server-Xorg-1.15.0-31.el6.x86_64
tigervnc-server-module-1.1.0-16.el6.x86_64

Attaching Xorg log.

Comment 13 Tomas Pelka 2015-04-28 10:04:33 UTC
(In reply to Milan Barta from comment #11)
> Created attachment 992192 [details]
> Xorg log
> 
> Hi,
> 
> I was able to reproduce the "blank screen" issue when connecting to a VNC
> server using an Xorg module.
> 
> The component versions I was able to reproduce on were:
> xorg-x11-drv-ati-7.3.99-2.el6.x86_64
> xorg-x11-server-Xorg-1.15.0-31.el6.x86_64
> tigervnc-server-module-1.1.0-16.el6.x86_64
> 
> Attaching Xorg log.

Milane could you please VERIFY with the fixed package? 

Thanks
Tom

Comment 14 Milan Barta 2015-04-29 13:41:24 UTC
Hi, confirming the bug is fixed with the latest packages
xorg-x11-drv-ati-7.5.99-3.el6.x86_64
xorg-x11-server-Xorg-1.15.0-33.el6.x86_64

Switching to VERIFIED.

Comment 16 errata-xmlrpc 2015-07-22 06:25:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1301.html


Note You need to log in before you can comment on or make changes to this bug.