Bug 1084191 - In System Settings -> Removable Devices, adding duplicates of USB device
Summary: In System Settings -> Removable Devices, adding duplicates of USB device
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kde-runtime
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1479818
TreeView+ depends on / blocked
 
Reported: 2014-04-03 19:29 UTC by Bill Sanford
Modified: 2018-10-26 07:58 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-04-10 11:31:43 UTC


Attachments (Terms of Use)
Screenshot of the entries in Removable Devices (638.53 KB, image/jpeg)
2014-04-03 19:29 UTC, Bill Sanford
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0717 None None None 2018-04-10 11:33 UTC

Description Bill Sanford 2014-04-03 19:29:46 UTC
Created attachment 882404 [details]
Screenshot of the entries in Removable Devices

Description of problem:
In KDE -> Start Menu -> System Settings -> Removable Devices -> Checkboxes enabled or disabled, if you plug in a USB device, there are two entries added for every time you insert, then remove and re-insert the USB device. 

Version-Release number of selected component (if applicable):
RHEL-7.0-20140317.0 
kde-runtime-4.10.5-7.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. See above
2.
3.

Actual results:
You get two entries for one USB device and it is repeated every time you insert/re-insert the USB device.

Expected results:
Only one entry should be there for one USB device and not repeated every time you insert the USB device.

Additional info:

Comment 1 RHEL Product and Program Management 2014-04-11 05:47:19 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 3 Jan Grulich 2016-04-07 07:23:24 UTC
Is this bug still reproducible with RLEH 7.2?

Comment 4 Bill Sanford 2016-08-04 19:23:15 UTC
I just installed RHEL-7.3-20160729.1 and it is still a problem.

Comment 5 Bill Sanford 2016-08-04 19:41:54 UTC
kde-runtime-4.10.5-8.el7.x86_64

Comment 7 Jan Grulich 2017-09-19 19:47:04 UTC
Fixed in kde-runtime-4.10.5-10.el7.

Comment 10 Bill Sanford 2018-02-15 14:51:38 UTC
Verified with kde-runtime-4.10.5-11.el7

Comment 13 errata-xmlrpc 2018-04-10 11:31:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0717


Note You need to log in before you can comment on or make changes to this bug.