Bug 108441 - com.arsdigita.web.DispatcherServlet should be marked 'load-on-startup' in web.xml
com.arsdigita.web.DispatcherServlet should be marked 'load-on-startup' in web...
Status: CLOSED RAWHIDE
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Ross
Jon Orris
:
Depends On:
Blocks: 109665
  Show dependency treegraph
 
Reported: 2003-10-29 11:11 EST by Daniel Berrange
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-25 17:20:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2003-10-29 11:11:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
The static class initialization block in com.arsdigita.web.DispatcherServlet is
responsible for running CCM startup procedures. Without these being run CCM will
not work in the slightest. The DispatcherServlet is instantiated on demand, when
request that maps to /ccm arrives. The problem is that before this time,
requests could arrive at other servlets or filters. These will fail because the
CCM startup will not have been run.

The solution is very simple. Change web.xml thus:

  <servlet>
    <servlet-name>ccm-dispatcher</servlet-name>
    <servlet-class>com.arsdigita.web.DispatcherServlet</servlet-class>
    <init-param>
      <param-name>fallback-servlet</param-name>
      <param-value>legacy-dispatcher</param-value>
    </init-param>
    <load-on-startup>1</load-on-startup>
  </servlet>



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make a request to a servlet that doesn't use BaseServlet
2. 
3.
    

Actual Results:  Some exception will be thrown

Expected Results:  The servlet operates normally

Additional info:
Comment 1 Justin Ross 2003-11-21 12:47:21 EST
The change Dan suggests was made in perforce change 38211.

Note You need to log in before you can comment on or make changes to this bug.