Bug 10846 - newer authconfig versions segfault on older systems
Summary: newer authconfig versions segfault on older systems
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: authconfig   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-16 00:49 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-31 15:38:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-04-16 00:49:27 UTC
(authconfig-3.0.3-1, other -3.0* also; authconfig-2.0-2 from RH61 works
fine)

Newer versions of authconfig seem to segfault on my heavily updated RH51
box.

glibc-2.0.7-19
popt-1.5-5x
newt-0.50.8-2
slang-1.4.0-2

And a few lines from strace:
-----
close(3)                                = 0
personality(PER_LINUX)                  = 0
getpid()                                = 9053
brk(0)                                  = 0x804eb90
brk(0x804ebc8)                          = 0x804ebc8
brk(0x804f000)                          = 0x804f000
open("/etc/popt", O_RDONLY)             = -1 ENOENT (No such file or
directory)
getuid()                                = 0
geteuid()                               = 0
open("/root/.popt", O_RDONLY)           = -1 ENOENT (No such file or
directory)
getuid()                                = 0
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++
-------

Comment 1 Bill Nottingham 2000-04-17 14:49:59 UTC
Um, the versions of popt, authconfig, slang, etc. are all
recompiled against glibc2.0, correct? (just making sure...)

Comment 2 Pekka Savola 2000-04-17 16:07:59 UTC
Yes.  All of those have been rebuilt from SRPMs.

Comment 3 Nalin Dahyabhai 2000-05-30 19:18:59 UTC
The next message I get when I strace authconfig is an opening of a message
catalog file.  Which version of gettext do you have installed?

Comment 4 Pekka Savola 2000-05-31 15:27:33 UTC
I'm unable to test this anymore, since I updated to Redhat 6.2.

Gettext was almost certainly the distribution binary from Redhat 5.1


Comment 5 Pekka Savola 2000-05-31 15:38:14 UTC
This is a test comment. Please disregard.


Note You need to log in before you can comment on or make changes to this bug.