Bug 108462 - Wallpaper not displayed at startup unless Nautilus is part of session
Wallpaper not displayed at startup unless Nautilus is part of session
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-29 14:42 EST by Torrey Hoffman
Modified: 2013-04-02 00:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-22 08:41:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Torrey Hoffman 2003-10-29 14:42:36 EST
Description of problem:  I removed Nautilus from my saved session (it's big,
slow and I rarely use it).  But now my screen background wallpaper is not shown
when I log in.  

However, if I open the control panel for the screen background and switch
backgrounds it is displayed correctly.  So obviously Nautilus is not actually
required for displaying the background.  

The X startup scripts should display the configured background without requiring
nautilus.

Version-Release number of selected component (if applicable):


How reproducible: every time


Steps to Reproduce:
1. Remove nautilus from saved session
2. Log out of X.
3. Log in again.
    
Actual results:
Screen background graphic is not displayed, until the control panel is used to
switch to/from another background.

Expected results:
Screen background should be displayed at login without requiring nautilus.

Additional info:
Comment 1 Michal Jaegermann 2003-12-11 03:36:15 EST
Results are the same when background is a solid color instead of
some wallpaper.  Background properties are remembered but not applied
unless Nautilus is running.  This bug was absent in RH9 and is
still present in FC1 release.
Comment 2 Alexander Larsson 2004-10-05 09:57:39 EDT
I think this is a gnome-settings-daemon bug.
Comment 3 Michal Jaegermann 2004-10-05 12:19:08 EDT
I did not really try to trace interactions but after

gconftool-2 -s --type=bool /apps/nautilus/preferences/show_desktop false

it is possible to set a background without running nautilus.
Not that intuitive. :-)
Comment 4 Marco Pesenti Gritti 2004-10-22 08:41:21 EDT
Closing since that is the wanted behavior. The pref was in the user
interface until GNOME 2.2 but than was removed.
Comment 5 Michal Jaegermann 2004-10-22 12:43:09 EDT
> .... that is the wanted behavior.
You have to be pulling my leg!  Wanted by whom?

Note You need to log in before you can comment on or make changes to this bug.